Results 1 to 2 of 2

Thread: Lab 3-11: Cấu hình EIGRP cơ bản

  1. #1

    Default Lab 3-11: Cấu hình EIGRP cơ bản

    Lab 3-11: Cấu hình EIGRP cơ bản




    Mô tả

    –Router R1, R2 sử dụng EIGRP để quảng cáo thông tin định tuyến
    –Router R1 hoạt động như DCE cung cấp xung clock cho router R2
    –Từ router R1, R2 ping được hết các địa chỉ trong mạng.

    - Mặc định, EIGRP cho phép summarization nên bạn cần sử dụng lệnh no auto-summarization để không cho phép tự động thực hiện summarization.
    - EIGRP hỗ trợ VLSM. Chú ý rằng mạng ethernet trên R1 và R2 sử dụng khoảng địa chỉ khác nhau là 131.108.1.0/25 và 131.108.1.128/25.
    - Metric của EIGRP bằng metric của IGRP nhân với 256.

    Cấu hình

    Router R1
    hostname R1
    !
    enable mật khẩu cisco
    !
    ip subnet-zero
    no ip domain-lookup
    !
    interface Loopback0
    ip address 199.100.4.1 255.255.255.0
    !
    interface Loopback1
    ip address 199.100.5.1 255.255.255.0
    !
    interface Loopback2
    ip address 199.100.6.1 255.255.255.0
    !
    interface Ethernet0
    ip address 131.108.1.1 255.255.255.128
    !
    interface Serial0
    ip address 199.100.3.1 255.255.255.0
    clock rate 64000
    !
    router eigrp 234
    network 131.108.0.0
    network 199.100.3.0
    network 199.100.4.0
    network 199.100.5.0
    network 199.100.6.0
    no auto-summary
    !
    end
    Router R2
    hostname R2
    !
    enable mật khẩu cisco
    !
    ip subnet-zero
    no ip domain-lookup
    !
    interface Loopback0
    ip address 199.100.7.1 255.255.255.0
    !
    interface Loopback1
    ip address 199.100.8.1 255.255.255.0
    !
    interface Loopback2
    ip address 199.100.9.1 255.255.255.0
    !
    interface Ethernet0
    ip address 131.108.1.129 255.255.255.128
    !
    interface Serial0
    ip address 199.100.3.2 255.255.255.0
    !
    router eigrp 234
    network 131.108.0.0
    network 199.100.3.0
    network 199.100.7.0
    network 199.100.8.0
    network 199.100.9.0
    no auto-summary
    !
    end

    Các bước thực hiện


    1. Đặt hostname, cấu hình cho cổng loopback, ethernet và serial trên router R1


    Router> en
    Router# conf t
    Router(config)# hostname R1
    R1(config)# no ip domain-lookup
    R1(config)# int e0
    R1(config-if)# ip addr 131.108.1.1 255.255.255.128
    R1(config-if)# no keepalive ← cho phép cổng Ethernet vẫn up khi không kết nối với bên ngoài
    R1(config-if)# no shut
    %LINK-3-UPDOWN: Interface Ethernet0, changed state to up
    %LINK-5-UPDOWN: Line protocol on Interface Ethernet0, changed state to up
    R1(config-if)# exit

    R1(config)# int lo0 ← Định nghĩa interface ảo để làm điểm kiểm tra
    R1(config-if)# ip addr 199.100.4.1 255.255.255.0
    R1(config-if)# int lo1
    R1(config-if)# ip addr 199.100.5.1 255.255.255.0
    R1(config-if)# int lo2
    R1(config-if)# ip addr 199.100.6.1 255.255.255.0
    R1(config-if)# exit

    R1(config-if)# int s0
    R1(config-if)# ip addr 199.100.3.1 255.255.255.0
    R1(config-if)# clock rate 64000 ← hoạt động như DCE cung cấp xung clock
    R1(config-if)# no shut


    2. Đặt hostname, cấu hình cho cổng loopback, ethernet và serial trên router R2


    Router(config)# hostname R2
    R2(config)# no ip domain-lookup

    R2(config)#int e0
    R2(config-if)# ip addr 131.108.1.129 255.255.255.128
    R2(config-if)# no keepalive
    R2(config-if)# no shut
    R2(config-if)# int lo0
    R2(config-if)# ip addr 199.100.7.1 255.255.255.0
    R2(config-if)# int lo1
    R2(config-if)# ip addr 199.100.8.1 255.255.255.0
    R2(config-if)# int lo2
    R2(config-if)# ip addr 199.100.9.1 255.255.255.0

    R2(config-if)# int s0
    R2(config-if)# ip addr 192.100.3.2 255.255.255.0
    R2(config-if)# no shut

    3. Cấu hình giao thức định tuyến EIGRP và lưu cấu hình vào NVRAM trên router R1


    R1(config)# router eigrp 234 ← kích hoạt quá trình định tuyến EIGRP trên router
    R1(config-router)# network 131.108.1.0 ← chỉ ra mạng sẽ quảng cáo và xác định cổng nào sẽ gởi và nhận thông tin định tuyến
    R1(config-router)# network 199.100.4.0
    R1(config-router)# network 199.100.5.0
    R1(config-router)# network 199.100.6.0
    R1(config-router)# network 199.100.3.0
    R1(config-router)# end
    R1# copy run start


    4. Cấu hình giao thức định tuyến EIGRP và lưu cấu hình vào NVRAM trên router R2


    R2(config)# router eigrp 234
    R2(config-router)# network 199.100.7.0
    R2(config-router)# network 199.100.8.0
    R2(config-router)# network 199.100.9.0
    R2(config-router)# network 131.108.1.0
    R2(config-router)# network 199.100.3.0
    R2(config-rputer)# end
    R2# copy run start


    Kiểm tra

    1. Dùng lệnh clear ip route * để xoá toàn bộ route từ bảng định tuyến.


    R1# clear ip route *

    2. Xem quá trình gửi nhận thông tin định tuyến IGRP bằng lệnh debug ip eigrp events


    R1# debug ip igrp events
    EIGRP event debugging is on


    3. Tắt chế độ debug bằng lệnh undebug all.


    R1# undebug all
    All possible debugging has been turned off


    4. Xem bảng định tuyến eigrp trên R1 và R2 bằng lệnh show ip route eigrp.


    R1# show ip route eigrp
    D 199.100.9.0/24 [90/2297856] via 199.100.3.2, 00:00:55, Serial0
    D 199.100.8.0/24 [90/2297856] via 199.100.3.2, 00:00:55, Serial0
    131.108.0.0/16 is variably subnetted, 2 subnets, 2 masks
    D 131.108.0.0/16 is a summary, 00:00:55, Null0
    D 199.100.7.0/24 [90/2297856] via 199.100.3.2 00:00:55, Serial0
    R1#


    Dựa vào bảng định tuyến, bạn có thể thấy có các route EIGRP học từ next-hop 199.100.3.2 và đi qua cổng S0. Trong các tuyến đường, có 1 tuyến đường đi đến Null0. Chú ý số AD trong trường hợp EIGRP là 90(RIP là 120, IGRP là 100 và OSPF là 110). D có nghĩa loại định tuyến là EIGRP. Metric của EIGRP bằng 256 lần metric của IGRP.

    Chú ý rằng mặc định EIGRP cho phép tự động thực hiện summarization. Router R1 không thấy mạng 131.108.1.128/25 bởi vì router R1 kết nối trực tiếp với mạng 131.108.1.0/25. Ta thấy tất cả các route đến từ mạng 131.108.0.0/16 đều được gửi đến Null0, nghĩa là tuyến đường đó sẽ bị loại bỏ.

    5. Từ router R1, ta thực hiện ping mạng 131.108.1.129/25


    R1#ping 131.108.1.129
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 131.108.1.130, timeout is 2 seconds:
    . . . . .
    Success rate is 0 percent (0/5)
    R1#

    Kết quả là không có hồi đáp do các gói gửi đến null0 sẽ bị loại bỏ.

    6. Để giải quyết vấn đề này ta cần thực hiện lệnh no auto-summary để không cho phép router tự động thực hiện summarization.


    R1(config)#router eigrp 234
    R1(config-router)#no auto-summary

    R2(config)#router eigrp 234
    R2(config-router)#no auto-summary


    7. Kiểm tra kết quả thực hiện

    R1# show ip route eigrp
    D 199.100.9.0/24 [90/2297856] via 199.100.3.2, 00:00:01, Serial0
    D 199.100.8.0/24 [90/2297856] via 199.100.3.2, 00:00:01, Serial0
    131.108.0.0/16 is variably subnetted, 2 subnets, 2 masks
    D 131.108.1.128/25 [90/2195456] via 199.100.3.2, 00:00:01, Serial0
    D 199.100.7.0/24 [90/2297856] via 199.100.3.2 00:00:01, Serial0
    R1#

    R1#ping 131.108.1.129
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 131.108.1.130, timeout is 2 seconds:
    ! ! ! ! !
    Success rate is 100 percent (5/5), round-trip min/avg/max = 16/16/16 ms
    R1#

    Chú ý rằng mạng 131.108.1.128/25 có trong bảng định tuyến. Từ router R1 ta ping thành công cổng Ethernet trên router R2. Để hiểu sâu thêm về vấn đề này, bạn cần tìm hiểu thêm về các chủ đề classful, classless và VLSM.
    Email : vnpro@vnpro.org
    ---------------------------------------------------------------------------------------------------------------
    Trung Tâm Tin Học VnPro
    149/1D Ung Văn Khiêm P25 Q.Bình thạnh TPHCM
    Tel : (08) 35124257 (5 lines)
    Fax: (08) 35124314

    Home page: http://www.vnpro.vn
    Support Forum: http://www.vnpro.org
    - Chuyên đào tạo quản trị mạng và hạ tầng Internet
    - Phát hành sách chuyên môn
    - Tư vấn và tuyển dụng nhân sự IT
    - Tư vấn thiết kế và hỗ trợ kỹ thuật hệ thống mạng

    Network channel: http://www.dancisco.com
    Blog: http://www.vnpro.org/blog

  2. #2

    Default

    sao không thêm bankwith zô cho bờ rồ lun

Similar Threads

  1. Lab 3-12: Redistribute giữa IGRP và EIGRP
    By admin in forum CCNA LabPro
    Replies: 5
    Last Post: 26-03-2009, 01:40 AM
  2. Lab 6-1: Cấu hình ISDN DDR
    By admin in forum CCNA LabPro
    Replies: 4
    Last Post: 24-08-2008, 06:56 PM
  3. tip: làm sao để cấu hình nhanh hơn
    By chipchipzzz in forum ICND 1 - Basic Router/Switch Config
    Replies: 1
    Last Post: 09-04-2006, 12:05 PM
  4. Replies: 0
    Last Post: 06-10-2004, 05:13 PM
  5. Replies: 4
    Last Post: 05-07-2003, 09:26 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •