Results 1 to 4 of 4

Thread: Lab 1-2: Đặt mật khẩu cho router

  1. #1

    Default Lab 1-2: Đặt mật khẩu cho router

    Lab 1-2: Đặt mật khẩu cho router



    Mô tả

    Thông thường có các loại mật khẩu để bảo mật cho một router Cisco như sau:
    – Loại mật khẩu đầu tiên là enable. Lọai này được sử dụng để vào chế độ enabled mode. Router sẽ yêu cầu bạn nhập mật khẩu này vào khi bạn đánh lệnh enable từ user mode để chuyển sang chế độ enable mode.
    – Ba loại còn lại là mật khẩu khi người dùng truy cập qua cổng console, cổng Aux, hay Telnet.

    ¤ Mật khẩu có phân biệt chữ hoa hay chữ thường (case sensitive), và không quá 25 ký tự. Các ký tự này có thể là chữ hoa, chữ thường, con số, các dấu chấm câu và khoảng cách; tuy nhiên ký tự đầu tiên không được là dấu trắng.

    Thực hiện

    Mật khẩu truy cập vào enable mode
    – Hai loại enable mật khẩu trên router, đặt bằng các lệnh sau:

    Router(config)#enable secret vip ¬ mật khẩu là vip
    Router(config)#enable password cisco ¬ mật khẩu là cisco

    – Ở chế độ mặc định, mật khẩu ở dạng không mã hóa (clear-text) trong file cấu hình; Lệnh enable secret password sẽ mã hóa các mật khẩu hiện có của router. Nếu có đặt enable secret, nó sẽ có hiệu lực mạnh hơn các mật khẩu còn lại.

    Mật khẩu truy cập vào User Mode

    1. Đặt mật khẩu cho user mode bằng lệnh line, xem xét các thông số theo sau bằng cách đánh dấu ? sau lệnh line.

    Router(config)#line ?
    <0-4> First Line number
    aux Auxiliary line
    console Primary terminal line
    vty Virtual terminal

    – aux đặt mật khẩu cho cổng aux, thường dùng khi cấu hình cho modem gắn router, quay số vào để cấu hình router.
    – console đặt mật khẩu trước khi vào user mode
    – vty đặt mật khẩu để telnet vào router. Nếu không đặt mật khẩu, không thể thực hiện telnet vào router.

    Để đặt mật khẩu cho user mode, cần xác định line muốn cấu hình và dùng lệnh login để router đưa ra thông báo chứng thực đòi hỏi nhập mật khẩu.

    2.Đặt mật khẩu trên cổng aux của router:

    vào global config mode đánh lệnh line aux 0.
    Chú ý rằng chỉ được chọn số 0 vì thông thường chỉ có một cổng auxilary trên router.

    Router#config t
    Enter configuration commands, one per line. End with CNTL/Z.
    Router(config)#line aux 0
    Router(config-line)#login
    Router(config-line)#password vip

    Câu lệnh login rất quan trọng, nếu không có lệnh này, router sẽ không thông báo đòi hỏi chứng thực.

    3. Đặt mật khẩu truy cập cho cổng console trên router: dùng lệnh line console 0

    Router(config)#line console 0
    Router(config-line)#login
    Router(config-line)#password vnpro

    4. Đặt mật khẩu telnet: dùng lệnh line vty

    Router(config-line)#line vty 0 4
    Router(config-line)#login
    Router(config-line)#password vnpro

    Sau khi router cấu hình địa chỉ IP, bạn có thể dùng chương trình Telnet để cấu hình và kiểm tra router thay vì sử dụng cáp console.
    Kiểm tra

    Kiểm tra lại các loại mật khẩu đã đặt bằng cách xem cấu hình hiện tại đang chạy, thực hiện lệnh show running-config:

    Router#show running-config
    Building configuration...

    Current configuration:
    !
    version 12.0
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname Router
    !
    enable secret 5 $1$Y3Hx$iF7j2hPkFe6/hwJG.NZOg.
    enable password cisco
    !
    !
    interface Ethernet0
    no ip address
    shutdown
    !
    interface Serial0
    no ip address
    shutdown
    !
    !
    line con 0
    password rrr
    login
    line aux 0
    password vip
    login
    line vty 0 4
    password RRR
    login
    !
    end

    Trong cấu hình ta thấy enable secret password ở dạng mã hóa. Các mật khẩu khác ở dạng không mã hóa. Hệ điều hành Cisco IOS cho phép mã hóa tất cả các mật khẩu trong file cấu hình bằng lệnh service password-encryption tại global configuration mode:

    Router#
    Router#conf ter
    Router(config)#service password-encryption
    Router(config)# [Ctrl–Z]
    Router#show running-config
    Building configuration...

    Current configuration:
    !
    version 12.0
    service password-encryption
    !
    hostname Router
    !
    enable secret 5 $1$Y3Hx$iF7j2hPkFe6/hwJG.NZOg.
    enable password 7 01100F175804
    !
    !
    interface Ethernet0
    no ip address
    shutdown
    !
    interface Serial0
    no ip address
    shutdown
    !
    !
    line con 0
    password 7 111B0B17
    login
    line aux 0
    password 7 0312521B
    login
    line vty 0 4
    password 7 1520393E
    login
    !
    end

    Tất cả các mật khẩu đã được mã hóa. Mật khẩu Enable secret vẫn ở dạng cũ; Mức độ mã hóa được hiển thị bằng chỉ số đứng ngay trước mỗi mật khẩu. Các giá trị có thể có của chỉ số này là:

    – 7 : mật khẩu được mã hóa theo thuật toán hai chiều MD7; mật khẩu dạng này có thể giải mã được.
    – 5 : mật khẩu được mã hóa theo thuật toán một chiều MD5; không thể giải mã được dạng này.
    – 0 : (hoặc không có giá trị) mật khẩu được hiển thị ở dạng không mã hóa.
    Nếu tắt chế độ mã hóa với câu lệnh no service password-encryption, thì mật khẩu vẫn ở dạng mã hóa trừ khi đặt lại mật khẩu.
    Last edited by tranmyphuc; 25-08-2008 at 10:09 PM.
    Email : vnpro@vnpro.org
    ---------------------------------------------------------------------------------------------------------------
    Trung Tâm Tin Học VnPro
    149/1D Ung Văn Khiêm P25 Q.Bình thạnh TPHCM
    Tel : (08) 35124257 (5 lines)
    Fax: (08) 35124314

    Home page: http://www.vnpro.vn
    Support Forum: http://www.vnpro.org
    - Chuyên đào tạo quản trị mạng và hạ tầng Internet
    - Phát hành sách chuyên môn
    - Tư vấn và tuyển dụng nhân sự IT
    - Tư vấn thiết kế và hỗ trợ kỹ thuật hệ thống mạng

    Network channel: http://www.dancisco.com
    Blog: http://www.vnpro.org/blog

  2. #2

    Default

    cam on anh,bai viet rat bo ich cho em,hien tai e dang rat can nhung tai lieu dang nhu the nay

  3. #3

    Default

    mình vừa là thành viên mới nên có câu hỏi mong bạn trả lời giúp. Cái enable secret < password > nếu mà không đặt thì cái lệnh enable password < password > nó có hiệu lực không? Mình dùng packet tracer để cấu hình router. Theo mình hiểu thì cái enable secret chỉ là để mã hóa password nhưng sao lại phải thêm password đằng sau và có thể gõ khác được. Mình mới học nên có chút không hiểu. Mong các member giúp cho mình . Thanks ^^

  4. #4

    Default

    Enable password sẽ có hiệu lực khi không có enable secret pass, nếu có 2 loại password này tồn tại, thì enable secret có hiệu lực, lúc này enable ko còn tác dụng.
    Trịnh Anh Luân
    - Email : trinhanhluan@vnpro.org
    - Search my site
    - Search VNPRO.ORG

    Trung Tâm Tin Học VnPro
    Địa chỉ: 149/1D Ung Văn Khiêm P25 Q.Bình thạnh TPHCM
    Tel: (08) 35124257 (5 lines)
    Fax: (08) 35124314

    Home page: http://www.vnpro.vn
    Support Forum: http://www.vnpro.org
    Network channel: http://www.dancisco.com
    • Chuyên đào tạo quản trị mạng và hạ tầng Internet
    • Phát hành sách chuyên môn
    • Tư vấn và tuyển dụng nhân sự IT
    • Tư vấn thiết kế và hỗ trợ kỹ thuật hệ thống mạng

    Blog: http://www.vnpro.org/blog
    Wifi forum: http://www.wifipro.org

Similar Threads

  1. Replies: 26
    Last Post: 02-03-2014, 09:16 AM
  2. Replies: 9
    Last Post: 20-06-2012, 02:04 PM
  3. Replies: 2
    Last Post: 24-08-2008, 03:09 PM
  4. Replies: 0
    Last Post: 08-10-2004, 02:28 PM
  5. lệnh dialer map
    By tuaninbox in forum ISCW
    Replies: 17
    Last Post: 03-06-2003, 12:52 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Website game điện thoại:Bigone