Results 1 to 4 of 4

Thread: Bài viết Multi-Layers Switch

  1. #1

    Default Bài viết Multi-Layers Switch

    1 GIỚI THIỆU CHUNG:

    Trong một hệ thống mạng máy tính, switch đóng vai trò thiết bị kết nối trung tâm và thường hoạt động ở layer 2 của mô hình OSI. Đối với một số dòng switch cao cấp như Catalyst 4000 trở về trước của Cisco hay Switch Procurve 8000 trở về trước của HP, một vài chức năng của layer 3 như là Broadcast control, IP Multicast,.QoS (IP Precedence, Protocol filter) được bổ sung để đáp ứng các nhu cầu ngày càng cao của hệ thống…Tuy nhiên các switch này không có được một số chức năng quan trọng của layer 3 như chức năng routing, IP dynamic VLAN… Do vậy các VLAN do các switch này tạo ra thường là static VLAN hay MAC dynamic VLAN. Mặc khác các VLAN không thể liên lạc được với nhau nếu không có router trung gian.

    Như vậy để 2 VLAN giao tiếp được với nhau, hệ thống mạng sẽ trở nên rắc rối hơn, khó quản lý hơn.

    Khái niệm multilayer switch (MLS) nói chung là một switch có thể thực hiện được một số các chức năng của các tầng cao hơn. Ở đây, chúng tôi chỉ trình bày các chức năng hoạt động ở tầng thứ 3 của mô hình OSI mà các switch trước đây không thực hiện được. MLS cung cấp một cách hiệu quả khả năng hoạt động ở layer 3 cho phần cứng của switch thông qua vi mạch chuyên dụng application-specific (ASIC) được tích hợp với phần cứng trong switch và bộ xử lý của router. Các chức năng của layer 3 có được trong switch loại này là do tích hợp thêm một vài thiết bị phần cứng như là RSM (Routing Switch Module), NFFC (NetFlow Feature Card), NRFC (Network Routing Feature Card)…vào switch truyền thống. Các thiết bị phần cứng này sẽ được đề cập chi tiết trong phần sau.

    Ví dụ sau cho ta thấy một switch có chức năng MLS sẽ kết nối được các VLAN như thế nào::

    Host A, B và C nằm trên các VLAN khác nhau : host A thuộc VLAN Sales, host B thuộc VLAN Maketing, host C thuộc VLAN Engineering. Thông qua một switch duy nhất (đã có thêm phần cứng là RSM) các host này đã giao tiếp được với nhau. Bảng tạo ra ở phần trên của hình chính là bảng routing do thiết bị phần cứng thêm vào switch đã tạo ra.


    Ta nhận thấy thiết bị phần cứng thêm vào switch đóng vai trò như một router. Nên việc tìm đường cũng dựa vào các routing protocol như Open Shortest Path First (OSPF), Enhanced Interior Gateway Routing Protocol (EIGRP), Routing Information Protocol (RIP), và Intermediate System-to-Intermediate System (IS-IS).

    Khái niệm switch layer 3 sẽ góp phần làm cho hệ thống đỡ phức tạp do giảm bớt các thiết bị (thay vì để 2 VLAN liên lạc được với nhau hệ thống cũ trước đây phải có 2 switch và 1 router thì bây giờ hệ thống chỉ cần quản lý 1 switch duy nhất). MLS còn có khả năng thống kê lưu lượng lưu thông các gói tin để giúp cho việc quản trị mạng. Thêm vào đó, hệ thống mạng với các switch này sẽ được cải thiện về tốc độ và giá thành.

    Đối với các sản phẩm switch Catalyst của Cisco, tính năng Multilayer switching tạo nên sự khác biệt giữa dòng sản phẩm 4000 và các dòng sản phẩm 5000 và 6000. Các dòng sản phẩm 5000, 6000 còn có một số chức năng bổ sung như Server Load Balancing, Enhanced QoS, FlexWAN… nhưng tính năng MultiLayer Switching đóng vai trò quan trọng nhất.
    In VnPro we trust

  2. #2

    Default RE: Bài viết Multi-Layers Switch

    2 CẤU HÌNH PHẦN CỨNG CẦN THIẾT ĐỂ CÓ CHỨC NĂNG MULTILAYER SWITCH

    Tài liệu này phân tích riêng về các sản phẩm switch Catalyst của Cisco. Các switch của các hãng khác khi muốn có thêm chức năng multilayer switching cũng có thể thêm vào các phần cứng có chức năng tương tự nhưng có thể có những tên gọi khác. Trong tài liệu này đề cập đến 2 dòng switch mới mà có thêm vào chức năng multilayer switch đó là Catalyst 5000 và Catalyst 6000.

    2.1 Đối với Switch Catalyst 5000 :

    Các thành phần cung cấp tính năng MLS gồm có :
    MLS-SE (Multilayer Switching - Switch Engine) : cụ thể là NetFlow Feature Card (NFFC) hoặc là NFFC II trong Supervisor Engine III or III F hoặc là Supervisor Engine II G / III G, và Catalyst đời 2926G. MLS-SE cung cấp dịch vụ Layer 3 LAN-switching.

    MLS-RP (Multilayer Switching - Router Processor) : là RSM hoặc RSFC hoặc là những router nối ngoài như Cisco 7500, 7200, 4700, 4500, or 3600 với phần mềm hỗ trợ IP MLS MLS-RP. MLS-RP cung cấp các dịch vụ về Cisco IOS-based multiprotocol routing và network.

    MLS-RP hoạt động như một router. Nó bao gồm một trong những thiết bị phần cứng sau:

    Route Swittch Module (RSM ):
    Catalyst 5500, 5505, 5509 có thêm một module vật lý RSM. Module này có khả năng hoạt động tương tự như một router. Có thể lắp module này vào bất kì slot nào trên switch ngoại trừ slot 1 và 2 (dành cho Supervisor và redundant supervisor engine).

    Bảng những đặc điểm kĩ thuật của RSM
    Mô tả Đặc điểm
    Bộ xử lý 2 bộ xử lý Mips R4700 RISC1 có tốc độ external là 50 MHz và tốc độ internal là 100 MHz.
    Bộ nhớ:
    DRAM2
    NVRAM
    Flash SIMM
    Flash Card
    Boot ROM
    32-MB (minimum), 64-MB, or 128-MB main and shared memory.
    Chấp nhận 8-MB (8 x 4), 16-MB (16 x 2 or 16 x 4), or 32-MB (32 x 4) SIMMs.
    128-KB nonvolatile EPROM cho file cấu hình hệ thống.
    8-MB or 16-MB onboard Flash SIMMs cho Cisco IOS images.
    16-MB or 20-MB PCMCIA card cho Cisco IOS images. RSM có 2 slot PCMCIA cung cấp kích thước lớn nhất cho bộ nhớ 40-MB Flash card.
    256-KB EPROM cho chương trình quản lý ROM.
    Những cổng giao tiếp 1 port serial console
    1 port serial auxiliary
    Backplane interface: 2 SAGE ASICs
    Regulatory compliance:
    Safety
    EMC
    Network xác nhận
    UL1950, CSA22.2-950, EN60950
    FCC-Part15-Class A, EN55022-Class B, CISPR22-Class B, VCCI-Class 2, CE Marking
    Net 1, Net 2, Net 3
    1RISC = Reduced Instruction Set Computing
    2DRAM = dynamic random-access memory
    Route Switch Feature Card (RSFC)

    Đối với họ switch Catalyst 5000, supervisor module là module tùy chọn. Có nhiều loại supervisor như Supervisor II, Supervisor II G, Supervisor III F, Supervisor III G… Trong đó Supervisor II G và Supervisor III G hỗ trợ cho RFSC. RFSC có thể gắn thêm vào các module này để phục vụ cho các chức năng ở layer 3 của switches.
    RSFC được xem như 1 module logic.Nếu Supervisor engine được gắn vào slot 1 thì RSFC được xem là module thứ 15. Nếu Supervisor engine được gắn vào slot 2 thì RSFC được xem là module thứ 16.
    Bảng những đặc điểm kĩ thuật cũa RSFC

    Mô tả Đặc điểm
    Bộ xử lý (Processor) 1 bộ sử lý Mips R4700 RISC với tốc độ 200 MHz.
    Cổng giao tiếp 1 cổng serial console (trên mặt trước của supervisor engine).
    Bộ nhớ
    DRAM1
    64-MB or 128-MB main and shared memory.
    NVRAM 128-KB nonvolatile EPROM cho file cấu hình hệ thống
    Flash SIMM 16-MB onboard Flash SIMMs cho Cisco IOS images.
    Boot ROM 256-KB EPROM cho chương trình quản lý ROM.
    Regulatory Compliance
    Safety UL1950, CSA22.2-950, EN60950
    EMC FCC-Part15-Class A, EN55022-Class B, CISPR22-Class B, VCCI-Class 2, CE Marking
    Network xác nhận Net 1, Net 2, Net 3

    1DRAM = dynamic random-access memory

    2.2Đối với Switch Catalyst 6000 :

    Để switch có chức năng của layer 3, hai phần cứng quan trọng được thêm vào là: Policy Feature Card (PFC) và Multilayer Switch Feature Card (MSFC)

    PFC :
    PFC chứa bảng Layer 3 switching (the Layer 3 MLS cache). MSL cache chưa thông tin luồng dữ liệu cho tất cả mọi hoạt động.
    PFC của switch 6000 có chức năng tương tự như MLS-SE của switch 5000.

    MSFC:
    MSFC được gắn bên trong supervisor engine, chạy phần mèn Cisco IOS router để liên lạc với những phần logic còn lại trên supervisor engine thông qua Interprocessor Communication (IPC) bus. Như thế, switch có MSFC có khả năng MLS (Layer 3 switching).
    MSFC của switch 6000 có chức năng tương tự nhu MLS-RP của switch 5000.
    MSFC được xem như là module logic thứ 15 nếu supervisor engine được gắn vào trong slot 1 và được xem như là module logic thứ 16 nếu supervisor engine được gắn vào trong slot 2.

    Hoạt động của MSFC :
    Packet đầu tiên đi từ nguồn đến đích theo cách routing thông thường. Ngay khi nó đến đích, supervisor engine học được tất cả thông tin mà nó cần để gởi đi những packet tiếp theo bằng con đường khác thông qua phần cứng của chính nó và bô xử lý router. Supervisor trình bày lại theo cách trình bày của layer 3 và thiết bị nơi nhận nghĩ rằng nó nhận được packet từ 1 router. Hoạt động này sẽ được trình bày chi tiết ở phần sau.
    In VnPro we trust

  3. #3

    Default

    3 NHỮNG CHỨC NĂNG CỦA LAYER 3 :
    Tất cả những phần cứng mà vừa trình bày ở trên đều cho switch có thêm các chức năng ở layer 3. Ở phần này ta sẽ khảo sát kĩ hơn để xem các phần cứng đó hoạt động ra sao để có các chức năng layer 3 đó. Đồng thời nghiên cưu các cách cấu hình cho các chức năng layer 3.

    3.1 INTERVLAN Routing

    3.1.1 Giới thiệu :

    Hệ thống mạng với các switch layer 2 thì các thiết bị trên những VLAN khác nhau không thể liên lạc trực tiếp với nhau. Chức năng layer 3 trên switch giúp các VLAN có thê liên lạc được với nhau mà không cần phải gián tiếp qua router.

    3.1.2 Các khái niệm :
    Trước khi đi qua phần khảo sát kĩ hoạt động của các phần cứng để có chức năng inter VLAN thì ta xem qua các khái niệm sau đây :

    Khái niệm luồng dữ liệu (flow):
    Khái niệm luồng dữ liệu tức là một hướng truyền và nhận dữ liệu duy nhất và các packet trên hướng đó phải cùng 1 giao thức. Nói cách khác, những luồng này là khác nhau nếu giao thức hoặc địa chỉ đầu gửi và nhận khác nhau. Tức là hướng packet đi từ A đến B khác packet đi từ B đến A. Packet đi từ A đến B với giao thức FTP khác packet từ A đến B với giao thức HTTP. Khái niệm luồng thông tin chỉ ở trên layer 3. Đặc điểm này cho phép các lưu thông IP từ những người dùng hoặc ứng dụng đến 1 đích xác định chỉ cần đi theo1 luồng dữ liệu duy nhất.

    Khái niệm Layer 3 MLS Cache:
    NFFC (hoặc NFFC II) chứa bảng Layer 3 switching (còn gọi là Layer 3 MLS cache) để chứa những thông tin về luồng dữ liệu. Cache này cũng bao gồm các thông tin về lưu lượng trên. Sau khi MLS cache được tạo, packet được nhận ra dựa vào thông tin luồng lưu trong bảng cache.

    Một mục trong cache sẽ được tạo mới ngay khi switch nhận được packet có luồng dữ liệu không giống tất cả các mục đã hiện diện trong cache.
    Mỗi một mục lưu thông tin về luồng dữ liệu có quy định thời gian tồn tại. Ta cũng có thể thay đổi thời gian đó.
    Kích thước lớn nhất của cache là 128K.

    3.1.3 Hoạt động của các phần cứng để có chức năng interVLAN:

    Khi 1 packet được chuyển đi ở layer 3 thì Switch (Switch ở đây đối với họ switch 5000 là MLS-SE, đối với họ 6000 là NFC) trình bày thông tin trong packet lại dưới dạng học được từ Router (Router ở đây đối với họ switch 5000 là MLS-RP, đối với họ 6000 là NSFC) và lưu giữ packet đó ở trong MLS cache.

    Nếu Host A và Host B khác VLAN. Host A gửi packet đến router để định được con đường đến Host B, switch nhận ra packet được gửi đến router nnờ vào địa chỉ MAC của router ở trên packet. Switch kiểm tra lại MLS cache thấy con đường chưa được xác định.

    Packet switch nhận có dạng như sau:
    Frame Header IP Header Payload
    Destination Source Destination Source TTL Checksum Data Checksum
    SWITCH MAC Host A MAC Host B IP Host A IP n calculation1
    Switch viết lại header của frame thuộc layer 2, thay đổi địc chỉ MAC của nơi đến thành địa chỉ MAC của Host B và địc chỉ MAC của nơi đi thành địa chỉ MAC của Router (những địc chỉ MAC này được lưu giữ trong MLS cache). Địa chỉ IP của Layer 3 vẫn tương tự như vậy, nhưng Time to Live (TTL) tăng 1 và checksum được tính toán lại.

    Switch chuyển tiếp packet vừa được viết lại đến VLAN của Host B và Host B nhận packet.

    Packet sau khi được switch viết lại có dạng như sau:

    Frame Header IP Header Payload
    Destination Source Destination Source TTL Checksum Data Checksum
    Host B MAC MLS-RP MAC Host B IP Host A IP n+1 calculation2
    Sau khi packet đầu tiên đã được chuyển đến Host

    B. Thông tin về dòng dữ liệu đã được lưu trong MLS cache. Những packet sau đó sử dụng lại những thông tin này để chuyển tiếp đến đích.

    Cụ thể hơn, ta mô tả lại quá trình hoạt động của Router và Switch đối với gói tin đầu tiên mà switch layer 3 nhận được để tạo ra một mục trong MLS cache qua 4 bước sau đây:

    Bước 1:

    Bước 2 :

    Bước 3 :


    Bước 4:



    3.1.4 Những phần mềm và phần cứng cần thiết :

    IP MLS đòi hỏi những phần mềm sau:

    Supervisor engine software release 4.1(1) hoặc những đời sau.

    Phần mềm IOS cho router Cisco:

    IOS release 12.0(3c)W5(8a) or later on the Route Switch Feature Card (RSFC)
    IOS release 12.0(3c)W5(8) or later on the MLS-RP if running MLS over ATM media
    IOS release 12.0(2) or later on Cisco 3600 series routers
    IOS release 11.3(2)WA4(4) or later on the Route Switch Module (RSM), or Cisco 7500, 7200, 4700, and 4500 series routers
    Nếu chạy MLS trên ATM media, Catalyst 5000 family ATM module software release 11.3(8)WA4(11) or later, or release 12.0(3c)W5(10) or later
    IP MLS đòi hỏi những phần cứng sau:
    Catalyst đời 2926G switch, hoặc Catalyst 5000 switch với Supervisor Engine II G or III G, or Supervisor Engine III or III F với NetFlow Feature Card (NFFC) or NFFC II
    RSM, RSFC, hay là những router ngoài như Cisco 7500, 7200, 4700, 4500, or 3600.
    Họ Catalyst 5000 với ATM module và router với cổng ATM nếu hoạt động MLS trên ATM media.
    (Tùy chọn) Những module có khả năng inline-rewrite ---Những module này có phần cứng onboard có khả năng cưc đại hoá khả năng IP MLS. Lệnh show port capabilities sẽ xác định được phần cứng hỗ trợ inline rewrite.

    3.1.5 Configuration
    IP MLS thường được cài đặt mặc định. Nhưng ta cũng có thể thay đổi cấu hình trên các cổng bằng các lệnh sau:
    Task Command
    Tắt khả năng IP MLS trên 1 cổng Router(config-if)# no mls ip
    Bật khả năng IP MLS trên 1 cổng Router(config-if)# mls ip
    Trình bày chi tiết IP MLS của mọi cổng show ip [interface]
    Ví dụ:
    Router(config-if)# no mls ip
    Router(config-if)# mls ip
    Router(config-if)#
    " Thiết lập INTERVLAN với RSM
    Lệnh session mod_num (slot lắp RSM) giúp truy cập vào RSM thông qua CLI.
    Ví dụ :
    Console> (enable) session 5
    Trying Router-5...
    Connected to Router-5.
    Escape character is '^]'.

    User Access Verification

    Password:
    Router>exit
    Console> (enable)

    " Thiết lập IP Intervlan với RSM:
    Thực hiện tiếp những lệnh sau trong chế độ configuration
    Task Command
    Step 1 (tùy chọn) Bật IP routing trên router. ip routing
    Step 2 (tùy chọn) Xác định một IP routing protocol. Router ip_routing_protocol
    Step 3 Xác định cổng VLAN trên RSM. Interface vlan-id
    Step 4 Xác định địa chỉ IP cho VLAN. ip address n.n.n.n mask
    Step 5 Thoát khỏi chế độ configuration. Ctrl-Z
    Ví dụ :
    Router#configure terminal
    Enter configuration commands, one per line. End with CNTL/Z.
    Router(config)#ip routing
    Router(config)#router rip
    Router(config-router)#network 10.0.0.0
    Router(config-router)#interface vlan 100
    Router(config-if)#ip address 10.1.1.1 255.0.0.0
    Router(config-if)#^Z
    Router#

    " Thiết lập IPX Intervlan với RSM
    Thực hiện những lệnh sau trong chế độ configuration
    Task Command
    Step 1 (tùy chọn) Bật IPX routing trên router. Ipx routing
    Step 2 (tùy chọn) Xáx định một IPX routing protocol. router ipx_routing_protocol
    Step 3 Xác định cổng VLAN trên RSM. Interface vlan-id
    Step 4 Xác định một network number cho VLAN. ipx network [network | unnumbered] encapsulation encapsulation-type

    Step 5 Thoát khỏi chế độ configuration. Ctrl-Z
    Ví dụ :
    Router#configure terminal
    Enter configuration commands, one per line. End with CNTL/Z.
    Router(config)#ipx routing
    Router(config)#ipx router rip
    Router(config-ipx-router)#network all
    Router(config-ipx-router)#interface vlan100
    Router(config-if)#ipx network 100 encapsulation snap
    Router(config-if)#^Z
    Router#
    " Thiết lập INTERVLAN với RSFC
    Lệnh session mod_num (module logic của RSFC) giúp truy cập vào RSFC thông qua CLI.
    Ví dụ:
    Console> (enable) session 15
    Trying Router-15...
    Connected to Router-15.
    Escape character is '^]'.

    User Access Verification

    Password:
    Router>exit
    Console> (enable)

    " Thiết lập IP Intervlan với RSFC
    Thực hiện những lệnh sau trong chế độ configuration
    Task Command
    Step 1 (tùy chọn) Bật IP routing trên router. ip routing
    Step 2 (tùy chọn) Xáx định một IP routing protocol. router ip_routing_protocol
    Step 3 Xác định cổng VLAN trên RSM. interface vlan-id
    Step 4 Xác định địa chỉ IP cho VLAN. ip address n.n.n.n mask
    Step 5 Thiết lập tình trạng "up" cho cổng, nếu cần no shutdown
    Step 6 Thoát khỏi chế độ configuration. Ctrl-Z
    Ví dụ:
    Router#configure terminal
    Enter configuration commands, one per line. End with CNTL/Z.
    Router(config)#ip routing
    Router(config)#router rip
    Router(config-router)#network 10.0.0.0
    Router(config-router)#interface vlan 100
    Router(config-if)#ip address 10.1.1.1 255.0.0.0
    Router(config-if)#no shutdown
    Router(config-if)#^Z
    Router#

    " Thiết lập IPX Intervlan với RSFC
    Thực hiện những lệnh sau trong chế độ configuration
    Task Command
    Step 1 (tùy chọn) Bật IPX routing trên router. Ipx routing
    Step 2 (tùy chọn) Xáx định một IPX routing protocol. router ipx_routing_protocol
    Step 3 Xác định cổng VLAN trên RSM. interface vlan-id
    Step 4 Xác định một network number cho VLAN ipx network [network | unnumbered] encapsulation encapsulation-type

    Step 5 Thiết lập tình trạng "up" cho cổng, nếu cần no shutdown
    Step 6 Thoát khỏi chế độ configuration. Ctrl-Z
    Ví dụ:
    Router#configure terminal
    Enter configuration commands, one per line. End with CNTL/Z.
    Router(config)#ipx routing
    Router(config)#ipx router rip
    Router(config-ipx-router)#network all
    Router(config-ipx-router)#interface vlan100
    Router(config-if)#ipx network 100 encapsulation snap
    Router(config-if)#no shutdown
    Router(config-if)#^Z
    Router#
    " Thiết lập INTERVLAN với MSFC (họ switch 6000)
    Để truy cập vào MSFC từ cổng switch command-line, thực hiện lệnh:
    Console> (enable) switch console [mod_num]
    Với mod_num là số thứ tự module logic của MSFC

    " Thiết lập IP Intervlan với MSFC
    Task Command
    Step 1 (tùy chọn) Bật IP routing trên router. Router(config)# ip routing
    Step 2 (tùy chọn) Xáx định một IP routing protocol. Router(config)# router ip_routing_protocol
    Step 3 Xác định cổng VLAN trên RSM. Router(config)# interface vlan-id
    Step 4 Xác định địa chỉ IP cho VLAN. Router(config-if)# ip address n.n.n.n mask
    Step 5 Thoát khỏi chế độ configuration. Router(config-if)# Ctrl-Z
    Ví dụ:
    Router# configure terminal
    Enter configuration commands, one per line. End with CNTL/Z.
    Router(config)# ip routing
    Router(config)# router rip
    Router(config-router)# network 10.0.0.0
    Router(config-router)# interface vlan 100
    Router(config-if)# ip address 10.1.1.1 255.0.0.0
    Router(config-if)# ^Z
    Router#
    " Thiết lập IPX Intervlan với MSFC: các lệnh cũng tương tự như với RSM
    Ví dụ:
    Router# configure terminal
    Enter configuration commands, one per line. End with CNTL/Z.
    Router(config)# ipx routing
    Router(config)# ipx router rip
    Router(config-ipx-router)# network all
    Router(config-ipx-router)# interface vlan100
    Router(config-if)# ipx network 100 encapsulation snap
    Router(config-if)# ^Z
    Router#
    In VnPro we trust

  4. #4

    Default

    3.2 IP MULTICAST MUTILAYER SWITCHING (IP MMLS)

    3.2.1 Giới thiệu:

    IP MMLS cũng tương tự như IP MLS, cung cấp 1 cách hiệu quả khả năng layer 3 cho phần cứng của switch thông qua vi mạch application-specific (ASIC) được tích hợp với phần cứng trong switch và bộ xử lý của router.

    Chúc năng multicast được hỗ trợ khi địa chỉ của phần nơi gưi thuộc về nhóm những địa chỉ multicast. Những packet không được hỗ trợ đường dẫn đến đích thì vẫn được chuyển tiếp bằng phần mềm trên router.

    Giao thức Independent Multicast (PIM) được dùng để tìm đường (route).

    3.2.2 Khái niệm về Layer 3 Multicast MLS Cache
    Switch (tức là PFC trong họ catalyst 6000 và MMLS-SE trong họ catalyst 5000) nằm trong Layer 3 MLS cache chứa các luồng thông tin muticast. Mỗi phần tử trong cache có dạng: {source IP, destination group IP, source VLAN}.

    Router và Switch trao đổi thông tin qua giao thức multicast Multilayer Switching (multicast MLSP).
    Khi router nhận được 1 luồng thông tin mới, nó cập nhật bảng multicast routing và chuyển tiếp thông tin mới đó đến Switch bằng multicast MLSP. Ngoài ra, nếu 1 phần tử trong bảng multicast routing bị quá hạn, router sẽ xóa phần tử đó và chuyển tiếp thông tin vừa cập nhật cho Switch.
    Lệnh clear ip mrouter để xóa bảng multicast routing.
    Lệnh no ip multicast-routing để tắt quá trình IP multicast routing.

    3.2.3 Quá trình hoạt động của IP MMLS

    Quá trình hoạt động của IP MMLS cũng tương tự như quá trình hoạt động của IP MLS.
    Switch (tức là MMLS-SE đối với họ switch 5000 hoặc là NFC đối với họ 6000), nhận được multicast packet có dạng như sau :
    Frame Header IP Header Payload
    Destination Source Destination Source TTL Checksum Data Checksum
    Group G1 MAC Server A MAC Group G1 IP Server A IP n calculation1
    Sau đó Switch sửa lại packet thành dạng sau :
    Frame Header IP Header Payload
    Destination Source Destination Source TTL Checksum Data Checksum
    Group G1 MAC MSFC MAC Group G1 IP Server A IP n-1 calculation2
    3.2.4 Những phần mềm và phần cứng cần thiết
    Supervisor engine software---Software release 5.1(1) or later
    Cisco IOS router software---IOS release 12.0(3c)W5(8) or later
    Catalyst 5000 family switch có Supervisor Engine II G or III G, or Supervisor Engine III or III F với NetFlow Feature Card II (NFFC II)
    Routing platform hỗ trợ IP multicast MLS:
    Họ Catalyst 5000 Route Switch Module (RSM) hoặc Route Switch Feature Card (RSFC)
    Cisco 7500, 7200, 4500, hoặc 3600 router sử dụng cho kết nối bên ngoài.
    Catalyst 8500 campus switch router (CSR) sử dụng cho kết nối bên ngoài.

    3.2.5 Configuration
    " Configuring IP MMLS trên Router
    (Router ở đây tức là MLS-RP đối với họ switch Catalyst 5000 hoặc là MSFC đối với họ Catalyst 6000)
    Bật chế độ IP multicast routing :
    Task Command
    Bật chế độ IP multicast routing trên router. Router(config)# ip multicast-routing
    Ví dụ :
    Router(config)# ip multicast-routing
    Router(config)#
    ¢ Lưu ý : IP PIM (Protocol Independent Multicast) phải được bật trên các cổng cũa router kết nối đến switch trước khi có chức năng IP MMLS trên những cổng này
    Task Command
    Bật IP PIM trên những cổng của router. Router(config-if)# ip pim {dense-mode | sparse-mode | sparse-dense-mode}

    Ví dụ bật PIM trên các cổng ở chế độ default(sparse-dense-mode):
    Router(config-if)# ip pim
    Router(config-if)#

    Ví dụ bật PIM trên các cổng ở chế độ sparse:
    Router(config-if)# ip pim sparse-mode
    Router(config-if)#
    Task Command
    Trình bày thông tin IP MMLS cho 1 cổng MSFC IP PIM trên router. show ip pim interface [type number] count
    Trình bày tình trạng hoạt động của IP MMLS trên một cổng của router. show ip interface
    Tắt IP MMLS
    Task Command
    Tắt IP MMLS trên các cổng của router. Router(config-if)# no mls ip multicast

    Ví dụ:
    Router(config-if)# no mls ip multicast
    Router(config-if)#
    Trình bày bảng IP multicast
    Task Command
    Trình bày bảng IP multicast routing. show ip mroute [group[source]] | [summary] | [count] | [active kbps]
    Ví dụ:
    Router# show ip mroute
    IP Multicast Routing Table
    Flags - Dense, S - Sparse, C - Connected, L - Local, P - Pruned
    R - RP-bit set, F - Register flag, T - SPT-bit set, J - Join SPT
    Outgoing interface Flags: H - Hardware switched
    Timers:Uptime/Expires
    Interface state:Interface, Next-Hop or VCD, State/Mode

    (*, 224.0.1.40), 00:01:15/00:00:00, RP 0.0.0.0, flagsJCL
    Incoming interface:Null, RPF nbr 0.0.0.0
    Outgoing interface list:
    Vlan800, Forward/Dense, 00:01:15/00:00:00

    (*, 224.1.1.1), 00:01:14/00:02:59, RP 0.0.0.0, flagsJC
    Incoming interface:Null, RPF nbr 0.0.0.0
    Outgoing interface list:
    Vlan5, Forward/Dense, 00:01:15/00:00:00
    Vlan4, Forward/Dense, 00:01:15/00:00:00
    Vlan3, Forward/Dense, 00:01:15/00:00:00
    Vlan2, Forward/Dense, 00:01:15/00:00:00

    (2.1.1.2, 224.1.1.1), 00:01:06/00:02:53, flags:CT
    Incoming interface:Vlan800, RPF nbr 0.0.0.0
    Outgoing interface list:
    Vlan2, Forward/Dense, 00:01:06/00:00:00, H
    Vlan3, Forward/Dense, 00:01:06/00:00:00, H
    Vlan4, Forward/Dense, 00:01:06/00:00:00, H
    Vlan5, Forward/Dense, 00:01:06/00:00:00, H
    Trình bày chi tiết thông tin MMLS trên router :
    Task Command
    Trình bày chi tiết IP MMLS trên tất cả các cổng. show mls ip multicast [[group[source][vlan-id]] |[*]]
    Trình bày tổng thể thông tin IP MMLS. show mls ip multicast summary
    Trình bày bảng thống kê IP MMLS. show mls ip multicast statistics
    Ví dụ cho thấy cách trình bày thông tin một mục IP MMLS trên router:
    Router# show mls ip multicast 224.1.1.1
    Multicast hardware switched flows:
    (1.1.13.1, 224.1.1.1) Incoming interface: Vlan13, Packets switched: 61590
    Hardware switched outgoing interfaces: Vlan20 Vlan9
    MFD installed: Vlan13

    (1.1.9.3, 224.1.1.1) Incoming interface: Vlan9, Packets switched: 0
    Hardware switched outgoing interfaces: Vlan20
    MFD installed: Vlan9

    (1.1.12.1, 224.1.1.1) Incoming interface: Vlan12, Packets switched: 62010
    Hardware switched outgoing interfaces: Vlan20 Vlan9
    MFD installed: Vlan12

    (1.1.12.3, 224.1.1.1) Incoming interface: Vlan12, Packets switched: 61980
    Hardware switched outgoing interfaces: Vlan20 Vlan9
    MFD installed: Vlan12

    (1.1.11.1, 224.1.1.1) Incoming interface: Vlan11, Packets switched: 62430
    Hardware switched outgoing interfaces: Vlan20 Vlan9
    MFD installed: Vlan11

    (1.1.11.3, 224.1.1.1) Incoming interface: Vlan11, Packets switched: 62430
    Hardware switched outgoing interfaces: Vlan20 Vlan9
    MFD installed: Vlan11

    Total hardware switched installed: 6
    Router#
    Ví dụ sau trình bày thông tin tổng thể IP MMLS trên router:
    Router# show mls ip multicast summary
    7 MMLS entries using 560 bytes of memory
    Number of partial hardware-switched flows:2
    Number of complete hardware-switched flows:5
    Router#
    " Configuring IP MMLS trên Switch
    (Switch ở đây tức là MLS-SE đối với họ switch Catalyst 5000 hoặc là PFC đối với họ Catalyst 6000)
    Để bật IP MMLS trên switch, làm những bước sau trong chế độ privileged:
    Task Command
    Bật IP MMLS trên switch. set mls multicast enable
    Kiểm tra lại MMLS. show mls multicast
    Ví dụ:
    Console> (enable) set mls multicast enable
    Multilayer Switching for Multicast is enabled for this device.
    Console> (enable)
    Tắt IP MMLS trên Switch
    Khi tắt IP MMLS trên switch, switch dừng quá trình multilayer switching IP multicast, bỏ tất cả những thông tin IP MMLS trong Layer 3 cache, và dừng tiến trình gửi multicast messages từ Router.
    Để tắt IP MMLS trên switch :
    Task Command
    Tắt IP MMLS trên switch. set mls multicast disable
    Kiểm tra lại MMLS. show mls multicast
    Ví dụ:
    Console> (enable) set mls multicast disable
    Multilayer Switching for Multicast is disabled for this device.
    Console> (enable)
    Trình bày thông tin IP cấu hình MMLS :
    Task Command
    Trình bày 1 cách tổng thể thông tin cấu hình IP MMLS. show mls multicast
    Ví dụ:
    Console> (enable) show mls multicast
    Admin Status: Enabled
    Operational Status: Active
    Configured flow mask is {Destination-source-vlan flow}
    Active Entries = 10
    Router include list :
    1.1.9.254 (Active)
    1.1.5.252 (Active)
    Console> (enable)
    Trình bày bảng thống kê thông tin IP MMLS:
    Task Command
    Trình bày bảng thống kê IP multicast trên Router. show mls multicast statistics [ip_addr]
    Ví dụ:
    Console (enable) show mls multicast statistics
    Router IP Router Name Router MAC
    -------------------------------------------------------
    1.1.9.254 ? 00-50-0f-06-3c-a0

    Transmit:
    Delete Notifications: 23
    Acknowledgements: 92
    Flow Statistics: 56

    Receive:
    Open Connection Requests: 1
    Keep Alive Messages: 72
    Shortcut Messages: 19
    Shortcut Install TLV: 8
    Selective Delete TLV: 4
    Group Delete TLV: 0
    Update TLV: 3
    Input VLAN Delete TLV: 0
    Output VLAN Delete TLV: 0
    Global Delete TLV: 0
    MFD Install TLV: 7
    MFD Delete TLV: 0
    Router IP Router Name Router MAC
    -------------------------------------------------------
    1.1.5.252 ? 00-10-29-8d-88-01

    Transmit:
    Delete Notifications: 22
    Acknowledgements: 75
    Flow Statistics: 22

    Receive:
    Open Connection Requests: 1
    Keep Alive Messages: 68
    Shortcut Messages: 6
    Shortcut Install TLV: 4
    Selective Delete TLV: 2
    Group Delete TLV: 0
    Update TLV: 0
    Input VLAN Delete TLV: 0
    Output VLAN Delete TLV: 0
    Global Delete TLV: 0
    MFD Install TLV: 4
    MFD Delete TLV: 0
    Console (enable)
    Xóa bảng thống kê IP MMLS:
    Task Command
    Xóa bảng thống kê IP MMLS trên switch. clear mls multicast statistics
    Ví dụ:
    Console> (enable) clear mls multicast statistics
    All statistics for the MLS routers in include list are cleared.
    Console> (enable)
    " Trình bày những mục IP MMLS:
    Trình bày những mục IP MMLS của switch :
    Task Command
    Trình bày những mục IP MMLS của switch Show mls multicast entry [[[mod] [vlan vlan_id] [group ip_addr] [source ip_addr]] | [all]]
    Ví dụ cho thấy cách trình bày tất cả những mục IP MMLS của switch:
    Console> (enable) show mls multicast entry all
    Router IP Dest IP Source IP Pkts Bytes InVlan OutVlans
    --------------- --------------- --------------- ---------- ----------- ------- --------

    1.1.5.252 224.1.1.1 1.1.11.1 15870 2761380 20
    1.1.9.254 224.1.1.1 1.1.12.3 473220 82340280 12
    1.1.5.252 224.1.1.1 1.1.12.3 15759 2742066 20
    1.1.9.254 224.1.1.1 1.1.11.1 473670 82418580 11
    1.1.5.252 224.1.1.1 1.1.11.3 15810 2750940 20
    1.1.9.254 224.1.1.1 1.1.12.1 473220 82340280 12
    1.1.5.252 224.1.1.1 1.1.13.1 15840 2756160 20
    1.1.9.254 224.1.1.1 1.1.13.1 472770 82261980 13
    1.1.5.252 224.1.1.1 1.1.12.1 15840 2756160 20
    1.1.9.254 224.1.1.1 1.1.11.3 473667 82418058 11
    Total Entries: 10
    Console> (enable)
    Ví dụ cho thấy cách trình bày tất cả những mục IP MMLS cho một Router đặc biệt:
    Console> (enable) show mls multicast entry 15
    Router IP Dest IP Source IP Pkts Bytes InVlan OutVlans
    --------------- --------------- --------------- ---------- ----------- ------- --------

    1.1.5.252 224.1.1.1 1.1.11.1 15870 2761380 20
    1.1.5.252 224.1.1.1 1.1.12.3 15759 2742066 20
    1.1.5.252 224.1.1.1 1.1.11.3 15810 2750940 20
    1.1.5.252 224.1.1.1 1.1.13.1 15840 2756160 20
    1.1.5.252 224.1.1.1 1.1.12.1 15840 2756160 20
    Total Entries: 5
    Console> (enable)
    Ví dụ cho thấy cách trình bày tất cả những mục IP MMLS của 1 nhóm địa chỉ đích đến multicast:
    Console> (enable) show mls multicast entry group 226.0.1.3 short
    Router IP Dest IP Source IP InVlan Pkts Bytes OutVlans
    -------------- ----------- ------------ ------ ------ --------- ---------
    171.69.2.1 226.0.1.3 172.2.3.8 20 171 23512 10,201,22,45
    171.69.2.1 226.0.1.3 172.3.4.9 12 25 3120 8,20
    Total Entries: 2
    Console> (enable)
    Ví dụ cho thấy cách trình bày tất cả những mục IP MMLS của một Router và 1 nhóm địa chỉ nơi đi multicast:
    Console> (enable) show mls multicast entry 15 1.1.5.252 source 1.1.11.1 short
    Router IP Dest IP Source IP Pkts Bytes
    InVlan OutVlans
    --------------- --------------- --------------- ---------- --------------------
    ------ ----------
    172.20.49.159 224.1.1.6 1.1.40.4 368 57776
    40 23,25
    172.20.49.159 224.1.1.71 1.1.22.2 99 65142
    22 30,37
    172.20.49.159 224.1.1.8 1.1.22.2 396 235620
    22 13,19
    Console> (enable)


    4 Ví dụ về InterVLAN Routing
    Ví dụ này bao gồm các phần sau
    " Example Network Topology
    " Catalyst 5509 Configuration
    " Catalyst 5505 Configuration
    " RSFC Configuration

    " Example Network Topology
    " 03 VLANs (IP subnets):
    o VLAN 50 (172.16.50.0/24)
    o VLAN 150 (172.16.150.0/24)
    o VLAN 250 (172.16.250.0/24)
    " 03 VLAN interface cấu hình trên RSFC:
    o Interface vlan50 (172.16.50.1)
    o Interface vlan150 (172.16.150.1)
    o Interface vlan250 (172.16.250.1)
    " Cấu hình của Catalyst 5509:
    o Supervisor Engine III G và RSFC trên slot 1
    o 12 port 100-Mbps Fast Ethernet module trên slot 2
    o 2-slot 48 port 10-Mbps Ethernet module trên slot 6
    " Cấu hình của Catalyst 5505:
    o Supervisor Engine III và Gigabit Ethernet uplink ports trên slot 1
    o 2-slot 48 port 10-Mbps Ethernet module trên slot 3
    " Catalyst 5509 và Catalyst 5505 kết nối với nhau thông qua Gigabit EtherChannel ISL trunk link trên ports 1/1-2.
    " VTP domain: "Corporate"
    " Catalyst 5509: VTP server và Catalyst 5505: VTP client


    Các bước cấu hình
    1. Cấu hình VTP server và gán VTP domain name cho switch 5509
    2. Cấu hình VTP client và gán VTP domain name cho switch 5505.
    3. Tạo VLANs trên Catalyst 5509.
    4. Cấu hình Gigabit EtherChannel ISL trunk link
    5. Gán các port vào VLAN
    6. Trên RSFC, tạo và gán IP addresses cho VLAN interfaces

    Sau khi cấu hình xong, tất cả các port jtrên switch có thể kết nối được với nhau.

    " Catalyst 5509 Configuration

    Cat5509> (enable) set VTP domain Corporate mode server
    VTP domain Corporate modified
    Cat5509> (enable) set vlan 50
    Vlan 50 configuration successful
    Cat5509> (enable) set vlan 150
    Vlan 150 configuration successful
    Cat5509> (enable) set vlan 250
    Vlan 250 configuration successful
    Cat5509> (enable) set port channel 1/1-2 desirable
    Port(s) 1/1-2 channel mode set to desirable.
    Cat5509> (enable) set trunk 1/1 desirable isl
    Port(s) 1/1 trunk mode set to desirable.
    Port(s) 1/1 trunk type set to isl.
    Cat5509> (enable) set port duplex 2/1 full
    Port 2/1 set to full-duplex.
    Cat5509> (enable) set vlan 50 2/1
    VLAN 50 modified.
    VLAN 1 modified.
    VLAN Mod/Ports
    ---- -----------------------
    50 2/1

    Cat5509> (enable) set port duplex 6/1 full
    Port 6/1 set to full-duplex.
    Cat5509> (enable) set vlan 150 6/1
    VLAN 150 modified.
    VLAN 1 modified.
    VLAN Mod/Ports
    ---- -----------------------
    150 6/1

    Cat5509> (enable)


    " Catalyst 5505 Configuration
    Cat5505> (enable) set VTP domain Corporate mode client
    VTP domain Corporate modified
    Cat5509> (enable) set port duplex 3/1 full
    Port 3/1 set to full-duplex.
    Cat5505> (enable) set vlan 250 3/1
    VLAN 250 modified.
    VLAN 1 modified.
    VLAN Mod/Ports
    ---- -----------------------
    250 3/1

    Cat5505> (enable)

    " RSFC Configuration
    Console> (enable) session 15
    Trying Router-15...
    Connected to Router-15.
    Escape character is '^]'.

    RSFC>enable
    RSFC#configure terminal
    Enter configuration commands, one per line. End with CNTL/Z.
    RSFC(config)#interface vlan50
    RSFC(config-if)#ip address 172.16.50.1 255.255.255.0
    RSFC(config-if)#no shutdown
    RSFC(config-if)#interface vlan150
    RSFC(config-if)#ip address 172.16.150.1 255.255.255.0
    RSFC(config-if)#no shutdown
    RSFC(config-if)#interface vlan250
    RSFC(config-if)#ip address 172.16.250.1 255.255.255.0
    RSFC(config-if)#no shutdown
    RSFC(config-if)#^Z
    RSFC#
    In VnPro we trust

Similar Threads

  1. Help em voi chuan bi thi skill sem3 rui ma...chan wa!
    By samurai_1012 in forum ICND 2 - Lan Switching
    Replies: 8
    Last Post: 09-11-2011, 08:56 PM
  2. CCNP Switching: Lab về dot1q Tunneling (rất dài)
    By dangquangminh in forum SWITCH / BCMSN
    Replies: 9
    Last Post: 21-06-2011, 05:25 AM
  3. Quản lý Port Swicht và Sercurity (Sercurity With Sw)
    By yarkken in forum ICND 2 - Lan Switching
    Replies: 2
    Last Post: 09-07-2010, 05:05 PM
  4. Quản lý port switch và port security
    By yarkken in forum ICND 2 - Lan Switching
    Replies: 4
    Last Post: 04-04-2010, 08:04 PM
  5. Lab 1-12: Nạp IOS image cho switch 2900, 3500
    By admin in forum CCNA LabPro
    Replies: 5
    Last Post: 16-12-2009, 09:41 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Website game điện thoại:Bigone