Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Cấu hình STP trên Catalyst Switch 2960

  1. #1
    Join Date
    Aug 2008
    Location
    VnPro
    Posts
    1,154

    Default Cấu hình STP trên Catalyst Switch 2960

    ITNEWS - Trong phần này các bạn sẽ được tìm hiểu về phương pháp cấu hình Spanning Tree Protocol (STP) trên port-based VLANs thực hiện trên Catalyst Switch 2960. Switch có thể dùng một trong hai giao thức PVST+ dựa trên chuẩn IEEE 802.1D hoặc giao thức rapid-PVST+ dựa trên chuẩn IEEE 802.1w.
    - Bài viết về Cấu hình STP sẽ bao gồm những bài viết nhỏ sau:
    + Phần I: Tìm hiểu về những tính năng của Spanning-tree
    + Phần II: Cấu hình một số tính năng của Spanning-Tree
    + Phần III: Hiển thị trạng thái Spanning-Tree

    Phần-I. Tìm hiểu về các tính năng của Spanning-Tree

    - Trong phần I của bài viết về cấu hình STP sẽ bao gồm những khái niệm sau:
    + Tổng quan về STP
    + Mô hình Spanning-Tree và BPDUs
    + Bridge ID, Switch Priority, Extended System ID
    + Trạng thái của các Interface Spanning-tree
    + Cách thức để một Switch hoặc Port của Switch trở thành Root switch hoặc Root Port
    + Spanning Tree và Kết nối dự phòng
    + Quản lý Spanning-tree Address
    + Dùng Accelerated Aging để giữ lại một kết nối
    + Các chế độ của Spanning-Tree và Các giao thức
    + Sự hỗ trợ của Spanning-tree Instances
    + Sự tương thích của Spanning-Tree
    + STP và IEEE 802.1Q Trunks.

    1. Tổng quan STP

    - STP là một giao thức quản lý liên kết layer 2, cung cấp một đường dự phòng trong khi vẫn ngăn cản được hiện tượng loop xảy ra trong hệ thống. Khi công nghệ Ethernet hoạt động ở Layer 2 trong mô hình OSI đã được cấu hình đúng, thì duy nhất một đường sẽ được hoạt động giữa hai PC. Trong hệ thống tồn tại nhiều đường cùng hoạt động giữa 2 PC sẽ là nguyên nhân của hiện tượng loop xảy ra. Nếu một loop tồn tại trong hệ thống, thì các thiết bị đầu cuối (PC) sẽ phải nhận nhiều các thông điệp trùng nhau (Cơ chế này gọi là Multi-Frame copy). Switch sẽ phải học thông tin về địa chỉ MAC của các PC trên nhiều port (Cơ chế này gọi là MAC Table Instable). Những hậu quả như vậy sẽ làm cho hệ thống của chúng ta trở nên không ổn định. Spanning-Tree hoạt động trên các switch sẽ có thể giúp hệ thống của chúng ta ngăn được loop và vẫn cho phép hệ thống xây dựng được mô hình có dự phòng.
    - STP sử dụng thuật toán Spanning-Tree để chọn một switch đóng vai trò làm Root Bridge trong mô hình hệ thống có dự phòng. Thuật toán Spanning-tree sẽ tính toán đường tốt nhất không có loop thông qua hệ thống switch layer2 bằng cách gán vai trò cho mỗi port hoạt động trong mô hình hệ thống đó, và mỗi port sẽ có một vai trò trong số những vai trò dưới đây:
    + Root: là một port có khả truyền dữ liệu trong mô hình spanning-tree
    + Designated: một port có khả năng truyền dữ liệu được chọn cho tất cả các switch trong segment LAN
    + Alternate: là một port sẽ bị blocked và port sẽ là port được dùng trong trường hợp dự phòng.
    + Backup: là một port blocked trong cấu hình loopback.
    - Switch có tất cả các port của nó đóng vai trò là designated hoặc đóng vai trò là backup thì swtich là root swtich. Switch có ít nhất một port của nó đóng vai trò là designated thì switch đó gọi là designated switch.
    - Spanning tree sẽ đưa đường dùng cho việc dự phòng trở về trạng thái standby (blocked). Nếu một hệ thống đang dùng spanning-tree bị lỗi xẩy ra và đường dự phòng vẫn có, thì thuật toán spanning-tree sẽ thực hiện việc tính toán lại mô hình spanning-tree và đưa đường dự phòng nên hoạt động. Các switch sẽ gửi và nhân các frame spanning-tree, những frame đó được gọi là Bridge Protocol Data Units (BPDUs). Có rất nhiều switch không thực hiện việc truyền những frame BPDUs nhưng những switch đó vẫn sử dụng để xây dựng đường không loop (loop-free). BPDUs chứa những thông tin về swtich gửi và các port của switch đó, bao gồm MAC address, switch priority, port priority, và cost path. Thuật toán Spanning-Tree sẽ sử dụng những thông tin đó để bầu chọn root swtich và root port cho hệ thống switch và các root port và designated port cho mỗi một phân đoạn mạng chuyển mạch (Colision domain = segment).
    - Khi hai port trên một switch là thành phần của một loop, giá trị độ ưu tiên của port spanning-tree và chi phí đường đi sẽ điều khiển và đưa một port trở về trạng thái forwarding (trạng thái truyền dữ liệu) và một port trở về trạng thái blocking. Giá trị độ ưu tiên của port sẽ đại diện cho vị trí của port đó mô hình hệ thống và hơn hết nó xác định vị trí để cho phép lưu lượng đi qua. Chi phí đường đi là giá trị đại diện cho tốc độ đường truyền.

    2. Mô hình Spanning-Tree và BPDUs


    - Spanning-tree hoạt động trong hệ thống switch sẽ được điều khiển bởi những thành phần sau:
    + Bridge ID (switch priority và MAC address) tương ứng với mỗi một VLan trên một switch
    + Spanning-Tree path cost đến root switch.
    + Port ID (port priority và MAC address) tương ứng với mỗi một interface layer 2 của switch.
    - Khi các switch trong hệ thống được khởi động, thì mỗi switch sẽ hoạt động với chức năng nhưn một root swtich. Mỗi switch sẽ gửi một cấu hình BPDU thông qua tất cả các port của switch đó đến các switch khác. BPDUs dùng để thông báo và tính toán mô hình spanning-tree. Mỗi gói BPDU có chứa những thông tin sau:
    + Bridge ID của switch đóng vai trò là root switch (trong trường hợp này chính là switch đang gửi gói BPDU)
    + Chi phí của đường tới root
    + Bridge ID của switch đang gửi gói BPDU
    + Thời gian tồn tại của gói BPDU
    + ID của port đã gửi BPDU ra ngoài qua port đó
    + Thời gian của gói Hello, Forward delay, và max-age.
    - Khi một switch nhận một gói tin BPDU có chứa những thông tin tốt hơn (như: Bridge ID thấp hơn, Chi phí đường đi thấp hơn), swtich đó sẽ lưu thông tin đó lại trên port của switch. Nếu BPDU này được nhận trên root port của switch thì switch đó sẽ chuyển tiếp gói BPDU này đến tất cả các designated Switch.
    - Nếu một switch nhận được một gói BPDU có chứa những thông tin không tốt bằng những thông tin mà switch đó đang có trên port đó thì switch đó sẽ hủy gói BPDU đi. Nếu switch đóng vai trò là designated switch cho mạng LAN mà nhận được một gói BPDU có thông tin không tin bằng những thông tin mà switch đó đang có trên port thì switch đó sẽ thay thế những thông tin tốt hơn của mình vào gói BPDU và sẽ gửi đi. Với phương pháp hoạt động như vậy, thì những thông tin không tốt sẽ bị hủy và những thông tin tốt hơn sẽ được quảng bá ra toàn bộ hệ thống.
    - Kết quả cuối cùng của việc trao đổi các gói BPUD giữa các switch sẽ là:
    + Một switch trọng hệ thống sẽ được bầu chọn là root switch. Trong mỗi Vlan, switch có priority cao nhất (giá trị số priority thấp nhất) sẽ được bầu chọn với vai trò là root switch. Nếu tất cả các switch trong hệ thống được cấu hình priority mặc định (32768), thì switch nào có địa chỉ MAC thấp nhất trong VLAN sẽ trở thành root switch
    + Một root port sẽ được chọn trên mỗi switch (trừ trường hợp là root switch). Port này sẽ cung cấp chi phí thấp nhất khi mà switch chuyển dữ liệu đến root switch.
    + Khoảng cách ngắn nhất đến root switch được tính toán cho mỗi switch dựa trên chi phí đường đi.
    + Một designated Switch cho mỗi LAN segment (Colision Domain) sẽ được chọn. Designated Switch sẽ phải có đường có chi phí thấp nhất khi chuyển dữ liệu từ mạng LAN đến Root Switch. Port được dùng để truyền dữ liệu thông qua nó trên designated switch được gắn vào mạng LAN gọi là designated port.
    - Tất cả các đường đi nếu không cần thiết để truyền dữ liệu đến root switch từ mọi nơi trên các switch trong mạng thì sẽ được đưa về trạng thái spanning-tree blocking.

    3. Bridge ID, Switch Priority, và Extended System ID.

    - Chuẩn IEEE 802.1D yêu cầu mỗi switch phải có duy nhất một bridge ID, được dùng trong quá trình bầu chọn root switch. Bởi vì mỗi VLAN có logical bridge khác nhau với PVST+ và rapid PVST+, trên cùng switch phải có các bridge ID khác nhau cho mỗi cấu hình VLAN. Mỗi VLan trên mỗi switch có duy nhất 8-byte bridge ID. Trong đó dùng 2 byte để xác định switch priority, và 6 byte còn lại dành cho switch MAC Address.
    - Catalyst switch 2960 hỗ trợ IEEE 802.1t spanning-tree mở rộng, và các bit trước kia được dùng cho switch priority thì bây giờ được sử dụng làm VLAN ID. Các bạn có thấy rằng trong 2 byte trước kia được dùng làm switch priority thì trong đó có 4-bit được dùng làm giá trị priority và 12-bit còn lại được mở rộng làm System ID tương ứng với VLAN ID.
    - Spanning tree sử dụng System ID mở rộng, switch priority và MAC address để làm bridge ID duy nhất trọng mỗi một VLAN.
    - Dựa vào việc các catalyst switch có hỗ trợ System ID, bạn có thể cấu hình để chọn root switch, secondary root switch, và switch priority cho mỗi VLAN. Ví dụ, khi bạn thay đổi giá trị switch priority, việc thay đổi đó có thể dẫn đến switch đó sẽ được bầu chọn làm root switch.

    4. Trạng thái của các interface Spanning-tree.

    - Mỗi một interface layer 2 của switch (port) sử dụng spanning tree sẽ hoạt động ở một trong các trạng thái sau:
    + Blocking: interface ở trạng thái này không có khả năng tham gia vào quá trình chuyển frame
    + Listening: là trạng thái đầu tiên của quá trình chuyển đổi từ trạng thái blocking khi spanning tree quyết định rằng interface này sẽ được tham gia vào trong quá trình chuyển frames.
    + Learning: Interface ở trạng thái này sẽ chuẩn bị tham gia vào quá trình chuyển frame
    + Forwarding: Interface ở trạng thái này sẽ có khả năng chuyển frame
    + Disable: Interface ở trạng thái này không được xử lý bởi spanning tree vì nó đang ở trạng thái shuttdown, hoặc không có liên kết, hoặc spanning tree đang không chạy trên port này.
    - Một interface sẽ chuyển đổi qua những trạng thái như sau:
    + Từ khởi tạo đến Blocking
    + Từ Blocking đến Listening hoặc Disable
    + Từ Listening to Learning hoặc Disable
    + Từ Learning đến Forwarding hoặc Disable
    + Từ Forwarding đến Disable.
    - Khi switch được khởi động, spanning tree được enable mặc định, và mọi interface trên switch, VLAN, hoặc hệ thống sẽ phải trải qua trạng thái blocking và bắt đầu chuyển đổi sang trạng thái Listening và learning. Spanning tree sẽ trở nên ổn định (mạng hội tụ) thì mỗi interface sẽ ở một trong hai trạng thái đó là Forwarding hoặc blocking.
    - Khi thuật toán spanning tree hoạt động tính toán để đưa một port của switch về trạng thái forwarding, thì tiến trình xử lý sẽ xảy ra theo tuần tự sau:
    + Một interface ở trạng thái listening trong khi spanning tree sẽ trờ cho thông tin để di chuyển interface sang trạng thái blocking.
    + Trong khi spanning tree đang trờ thời gian forward-dely hết, nó sẽ di chuyển interface sang trạng thái learning và khởi động lại thời gian forward-delay.
    + Ở trạng thái learning, interface sẽ tiếp tục ngăn những frame đến nó nhưng nó vẫn học những thông tin về địa chỉ MAC vào trong bảng CAM .
    + Khi thời gian forward-dely hết, spanning-tree chuyển đổi trạng thái interface sang trạng thái forwarding.

    a. Trạng thái Blocking

    - Một interface ở trạng thái Blocking sẽ không có khả năng chuyển frame dữ liệu. Sau khi khởi tạo, một BPDU sẽ được gửi đến mỗi port của switch. Một switch sẽ khởi tạo vai trò root cho đến khi switch đó trao đổi các gói BPUD với những switch khác. Sau khi trao đổi được thiết lập thì switch sẽ có khả năng trở thành root hoặc root switch. Nếu có duy nhất một switch trong hệ thống mạng thì sẽ không có sự trao đổi các gói BPDU, thời gian forward-delay hết, thì interface sẽ chuyển sang trạng thái Listening. Một interface của switch sẽ luôn ở trạng thái blocking khi switch bắt đầu khởi động.
    - Một interface của switch ở trạng thái blocking sẽ có những khả năng sau:
    + Hủy tất cả các frame mà switch đó nhận được thông qua port này.
    + Không có khả năng học địa chỉ MAC.
    + Có khả năng nhận các gói BPDUs.

    b. Trạng thái Listening:

    - Đây là trạng thái tiếp theo của một interface sau khi hết thời gian forward-delay của trạng thái blocking. Interface sẽ được chuyển đổi sang trạng thái này khi spanning tree quyết định là interface này sẽ được tham gia vào trong quá trình chuyển frame dữ liệu.
    - Một interface ở trạng thái Listening sẽ có những vai trò sau:
    + Hủy những frame nhận được từ interface này
    + Hủy những frame chuyển mạch từ interface khác
    + Không học địa chỉ MAC
    + Có khả năng nhận các gói BPDUs

    C. Trạng thái Learning

    - Khi một interface đã chuyển sang trạng thái learning, thì interface đó sẽ có những khả năng dưới đây:
    + Hủy tất cả những frame nhận được trên interface này.
    + Hủy tất cả những frame chuyển mạch từ interface khác.
    + Có khả năng học địa chỉ MAC để xây dựng bảng MAC table.
    + Có khả năng nhận các gói BPDU.

    D. Trạng thái Forwarding.

    - Khi một port hoạt động ở trạng thái forwarding thì port sẽ có những khả năng sau:
    + Nhận và chuyển tất cả các frame mà switch đó nhận được thông qua interface này.
    + Chuyển tất cả những frame được chuyển đến từ interface khác.
    + Học địa chỉ MAC
    + Nhận các gói BPDU.

    E. Trạng thái Disable.

    - Một interface ở trạng thái này sẽ thực thi những chức năng sau:
    + Hủy tất cả các frame nhận được thông qua interface này
    + Hủy tất cả các frame chuyển từ port khác sang
    + Không học địa chỉ MAC
    + Không nhận các gói BPDU

    Trong bài viết tiếp theo các bạn sẽ được giới thiệu về các chuyên đề còn lại của Phần I: Tìm hiểu về các tính năng của Spanning-Tree.
    Phan Hoàng Gia Liêm - Instructor
    Email : gialiem@vnpro.org
    Yahoo : gialiem_vnpro
    -----------------------------------------------------------------------------------------------
    Trung Tâm Tin Học VnPro
    149/1D Ung Văn Khiêm P25 Q.Bình thạnh TPHCM
    Tel : (08) 35124257 (5 lines)
    Fax: (08) 35124314

    Home page: http://www.vnpro.vn
    Support Forum: http://www.vnpro.org
    - Chuyên đào tạo quản trị mạng và hạ tầng Internet
    - Phát hành sách chuyên môn
    - Tư vấn và tuyển dụng nhân sự IT
    - Tư vấn thiết kế và hỗ trợ kỹ thuật hệ thống mạng

    Network channel: http://www.dancisco.com
    Blog: http://www.vnpro.org/blog

  2. #2
    Join Date
    Aug 2008
    Location
    VnPro
    Posts
    1,154

    Default

    II - Phần II: Cấu hình một số tính năng của Spanning-Tree
    - Trong phần II tiếp theo này sẽ bao gồm những chủ đề sau:
    + Cấu hình Spanning-tree mặc định
    + Cấu hình Spanning-tree theo hướng dẫn.
    + Thay đổi các phương thức hoạt động của Spanning-tree
    + Disable Spanning Tree

    + Cấu hình một Switch trở thành Root Switch.
    + Cấu hình một một Secondary Root Switch.
    + Cấu hình độ ưu tiên của port (Port Priority)
    + Cấu hình chi phí cho các đường đi (Path Cost)
    + Cấu hình độ ưu tiên của switch trong một Vlan
    1. Cấu hình Spanning Tree mặc định

    - Bảng 3.1 là danh sách các tham số mặc định của Spanning - Tree.



    2. Cấu hình Spanning Tree theo hướng dẫn.

    - Nếu có nhiều hơn một Vlan được tạo ra trong một VTP domain thì sẽ tồn tại nhiều spanning-tree instances (Mỗi một Vlan sẽ tồn tại một Spanning-tree instance), bạn có thể enable PVST+ hoặc rapid PVST+ trên 128 VLANs trên một switch. Những VLANs còn lại thì spanning-tree sẽ bị disable. Tuy nhiên, bạn có thể ánh xạ nhiều VLANs vào cùng một spanning-tree instances bằng cách sử dụng MSTP.
    - Nếu có 128 instances của spanning tree đã thực sự đang sử dụng, thì bạn có thể disable spanning tree trên một VLANs nào đó còn lại và sau đó bạn sẽ enable spanning tree trở lại. Sử dụng câu lệnh no spanning-tree vlan vlan-id trong chế độ global configuration để disable spanning tree trên một VLAN, và sử dụng spanning-tree vlan vlan-id trong chế độ global configuration để enable spanning tree trên VLAN đó.
    - Các câu lệnh có liên quan đến từ khóa "Spanning-tree" sẽ được dùng để điều khiển các thông số cấu hình của một instances spanning-tree trên một VLAN. Bạn sẽ tạo một spanning-tree instance khi bạn gán một interface của switch vào một VLAN. Spanning-tree instace sẽ được bỏ khi interface đó được gán sang một VLAN khác. Bạn có thể cấu hình các tham số cho switch và các port của switch trước khi một spanning-tree instace được tạo, những tham số đó sẽ được thực thi ngay lập tức khi spanning-tree được tạo.
    - Switch có khả năng hỗ trợ PVST+, rapid PVST+, và MSTP, nhưng duy nhất một trong số các phiên bản đó có thể được hoạt động ở một thời điểm (cho ví dụ: tất cả các vlan cùng chạy PVST+; tất cả các vlan cùng chạy rapid PVST+, hoặc tất cả các VLAN cùng chạy MSTP).

    3. Thay đổi các phương thức hoạt động của Spanning-tree.

    - Switch có khả năng hỗ trợ nhiều phương thức hoạt động như: PVST+, rapid-PVST+, hoặc MSTP. Theo mặc định, thì tất cả các switch chạy giao thức PVST+.
    - Bắt đầu với chế độ privileged EXEC, các bạn có thể thực hiện những bước sau để có thể thay đổi được các phương thức hoạt động của Spanning-tree. Nếu bạn muốn cho phép một phương thức khác hoạt động so với phương thức đang hoạt động theo mặc định thì bạn có thể thực hiện những câu lệnh sau:

    Example:
    Switch_ITNEWS# configure termial
    Swtich_ITNEWS(config)# spanning-tree mode rapid-pvst
    Switch_ITNEWS(config)# interface fa0/10
    Switch_ITNEWS(config-if)# spanning-tree link-type point-to-point
    Switch_ITNEWS(config-if)# end
    Switch_ITNEWS# clear spanning-tree detected-protocols
    Switch_ITNEWS# show spanning-tree summary
    Switch_ITNEWS# show spanning-tree interface fa0/10
    Switch_ITNEWS# copy running-config startup-config

    - Để có thể trở về phương thức hoạt động mặc định của spanning-tree các bạn có thể sử dụng câu lệnh: no spanning-tree ở chế độ global configuration. Và để port của switch trở về cấu hình mặc định, sử dụng câu lệnh: no spanning-tree link-type ở chế độ interface configuration.

    4. Disable Spanning Tree

    - Spanning-tree được hoạt động mặc định trên VLAN 1 và trên tất cả các VLAN được tạo về sau này. Để disable spanning-tree thì bạn chỉ nên disable spanning-tree trong hệ thống mạng mà bạn có thể chắc chắn rằng nó không có loop xảy ra.
    - Bắt đầu từ chế độ privileged EXEC, các bạn sẽ thực hiện các câu lệnh sau đây theo thứ tự để có thể disable spanning-tree trên một VLAN:

    Example:
    Switch_ITNEWS# configure terminal
    Switch_ITNEWS(config)# no spanning-tree vlan 2
    Switch_ITNEWS(config)# end
    Switch_ITNEWS# show spanning-tree vlan 2
    Switch_ITNEWS# copy running-config startup-config.

    - Để cho phép spanning-tree hoạt động trở lại trên một VLAN nào đó các bạn có thể dùng câu lệnh: spanning-tree vlan vlan-id trong chế độ global configuration.

    5. Cấu hình một Switch trở thành Root Switch.

    - Switch sẽ luôn duy trì một spanning-tree instance riêng biệt trên một một vlan được cấu hình trên nó. Một bridge ID, sẽ chứa cả hai tham số: switch priority và switch MAC Address. Trong mỗi một VLAN, switch nào có bridge ID thấp nhất sẽ trở thành root switch cho vlan đó.
    - Để cấu hình một switch trở thành một root cho một vlan, sử dụng câu lệnh spanning-tree vlan vlan-id root ở chế độ global configuration để sửa đổi switch priority từ giá trị mặc định (32768) thành một giá trị thấp hơn. Khi bạn nhập vào câu lệnh đó, thì hệ điều hành sẽ kiểm tra switch priority của root switch cho mỗi một vlan. Bởi vì các switch có khả năng hỗ trợ mở rộng ID hệ thống, nên các switch sẽ cấu hình priority của nó thành giá trị 24576 và với giá trị này sẽ làm cho switch có giá trị priority thấp hơn so với các switch khác có giá trị priority mặc định và khi đó switch này sẽ trở thành root switch trong vlan này.
    - Nếu root switch trong một vlan có giá trị priority thấp hơn giá trị 24576, thì khi một switch dùng câu lệnh spanning-tree vlan vlan-id root sẽ lấy một giá trị priority thấp hơn 4096 và nó sẽ trở thành root switch.
    - Bắt đầu từ chế độ privileged EXEC, các bạn có thể thực hiện những câu lệnh sau để cấu hình:

    Example:
    Switch_ITNEWS# configure termial
    Switch_ITNEWS(config)# spanning-tree vlan 2 root primary
    Switch_ITNEWS(config)# end
    Switch_ITNEWS# show spanning-tree detail
    Switch_ITNEWS# copy running-config startup-config

    - Để trở về cấu hình mặc đinh, sử dụng câu lệnh no spanning-tree vlan vlan-id root ở chế độ global configuration.

    6. Cấu hình một Secondary Root Switch.

    - Khi bạn cấu hình một switch với vai trò là secondary root, thì switch đó sẽ được điều chỉnh lại priority từ giá trị mặc định thành giá trị 28672. Switch này sẽ trở thành root switch trong một vlan khi mà root switch trở nên không hoạt động hoặc bị lỗi.
    - Bạn có thể thực thi câu lệnh này trên nhiều switch để cấu hình nhiều switch giữa vai trò dự phòng cho root switch: spanning-tree vlan vlan-id root primary ở chế độ global configuration.
    - Các bạn có thể xem ví dụ dưới để lắm được phương pháp cấu hình Secondary Root switch:

    example:
    Switch_ITNEWS# configure terminal
    Switch_ITNEWS(config)# spanning-tree vlan 2 root secondary.
    Switch_ITNEWS(config)# end
    Switch_ITNEWS# show spanning-tree detail
    Switch_ITNEWScopy run start

    7. Cấu hình độ ưu tiên cho port của switch (Port Priority).

    - Nếu hiện tượng loop xảy ra trong hệ thống mạng, giao thức spanning tree sẽ sử dụng port priority khi chọn mộ interface và đưa interface đó trở về trạng thái forwarding. Bạn có thể gán giá trị priority cao hơn cho những interface mà bạn muốn chọn đầu tiên và giá trị priority thấp hơn cho những interface bạn muốn chọn cho những lần sau. Nếu tất cả các interface đều có cùng giá trị priority, spanning tree sẽ đưa một interface có giá trị priority thấp nhất về trạng thái forwarding và blocks những interface còn lại.
    - Để có thể thay đổi được giá trị priority cho các interface các bạn có thể thực hiện những câu lệnh sau trên switch của mình:

    example:
    Switch_ITNEWS# configuration terminal
    Switch_ITNEWS(config)# interface fa0/10
    Switch_ITNEWS(config-if)# spanning-tree port-priority 112
    Switch_ITNEWS(config-if)# spanning-tree vlan 2 port-priority 112
    Switch_ITNEWS(config-if)# end
    Switch_ITNEWS# show spanning-tree interface fa0/10
    Switch_ITNEWS# show spanning-tree vlan 2
    Switch_ITNEWS# copy run start

    8. Cấu hình chi phí cho các đường đi (Path Cost)

    - Giá trị mặc định của spanning-tree path cost được lấy từ tốc độ đường truyền của một interface. Nếu trọng hệ thống mạng có loop xảy ra, spanning tree sẽ sử dụng cost khi chọn một interface để đưa interface đó về trạng thái forwarding. Bạn có thể gán giá trị cost thấp hơn cho một interface khi bạn muốn chọn interface đó lần đầu tiên và giá trị cost cao hơn cho một interface khác khi bạn muốn chọn interface đó ở lần cuối cùng. Nếu tất cả các interface có cùng một giá trị cost, spanning tree sẽ đưa interface có giá trị cost thấp nhất trở về trạng thái forwarding và blocks những interface còn lại.
    - Để có thể thay đổi được cost cho các interface bạn có thể tham khảo ví dụ dưới đây:

    Example:
    Switch_ITNEWS# configure terminal
    Switch_ITNEWS(config)# interface fa0/11
    Switch_ITNEWS(config-if)# spanning-tree cost 10
    Switch_ITNEWS(config-if)# spanning-tree vlan 2 cost 10
    Switch_ITNEWS(config-if)# end
    Switch_ITNEWS# show spanning-tree interface fa0/11
    Switch_ITNEWS# show spanning-tree vlan 2
    Switch_ITNEWS# copy run start

    9. Cấu hình Switch priority cho VLAN.

    - Bạn có thể cấu hình switch priority và có thể làm cho switch đó được lựa chọn làm root switch.
    - Để có thể cấu hình Switch priority cho switch các bạn có thể thực hiện những câu lệnh sau:

    Example:
    Switch_ITNEWS# configure terminal
    Switch_ITNEWS(config)# spanning-tree vlan 2 priority 4096
    Switch_ITNEWS(config)# end
    Switch_ITNEWS# show spanning-tree vlan 2
    Switch_ITNEWS# copy run start

    III- Phần III: Hiển thị trạng thái Spanning-Tree

    Để hiển thị các trạng thái của spanning-tree các bạn có thể sử dụng một trong số các câu lệnh sau:
    - Switch_ITNEWS# show spanning-tree active
    - Switch_ITNEWS# show spanning-tree detail
    - Switch_ITNEWS# show spanning-tree interface fa0/10
    - Switch_ITNEWS# show spanning-tree summary

    Với phần II và phần III của bài viết này đã kết thúc loạt các bài viết về giao thức Spanning tree protocol. Hy vọng rằng với kiến thức của những bài viết này sẽ có thể phần nào giúp các bạn hiểu rõ và cấu hình được giao thức này trong hệ thống mạng core switch cho doanh nghiệp của các bạn.

    nguồn:http://www.itnews.com.vn
    Last edited by hoanggialiem; 11-04-2009 at 07:11 AM.
    Phan Hoàng Gia Liêm - Instructor
    Email : gialiem@vnpro.org
    Yahoo : gialiem_vnpro
    -----------------------------------------------------------------------------------------------
    Trung Tâm Tin Học VnPro
    149/1D Ung Văn Khiêm P25 Q.Bình thạnh TPHCM
    Tel : (08) 35124257 (5 lines)
    Fax: (08) 35124314

    Home page: http://www.vnpro.vn
    Support Forum: http://www.vnpro.org
    - Chuyên đào tạo quản trị mạng và hạ tầng Internet
    - Phát hành sách chuyên môn
    - Tư vấn và tuyển dụng nhân sự IT
    - Tư vấn thiết kế và hỗ trợ kỹ thuật hệ thống mạng

    Network channel: http://www.dancisco.com
    Blog: http://www.vnpro.org/blog

  3. #3

    Default

    thanks bác vì bài rất hay

  4. #4

    Default

    bài viết rất hay. Mong được anh chỉ dẫn thêm về giao thức Multiple Spanning Tree

  5. #5

    Default

    Bài viết của a rất hay. Mong a chỉ dùm e cấu hình " Cisco secure ACS " trên Switch Catalyst 2960.

  6. #6
    Join Date
    Aug 2008
    Location
    VnPro
    Posts
    1,154

    Default

    Quote Originally Posted by oliverken00 View Post
    Bài viết của a rất hay. Mong a chỉ dùm e cấu hình " Cisco secure ACS " trên Switch Catalyst 2960.
    Gởi bạn tài liệu tham khảo: http://www.cisco.com/en/US/docs/net_...de/deploy.html
    Phan Hoàng Gia Liêm - Instructor
    Email : gialiem@vnpro.org
    Yahoo : gialiem_vnpro
    -----------------------------------------------------------------------------------------------
    Trung Tâm Tin Học VnPro
    149/1D Ung Văn Khiêm P25 Q.Bình thạnh TPHCM
    Tel : (08) 35124257 (5 lines)
    Fax: (08) 35124314

    Home page: http://www.vnpro.vn
    Support Forum: http://www.vnpro.org
    - Chuyên đào tạo quản trị mạng và hạ tầng Internet
    - Phát hành sách chuyên môn
    - Tư vấn và tuyển dụng nhân sự IT
    - Tư vấn thiết kế và hỗ trợ kỹ thuật hệ thống mạng

    Network channel: http://www.dancisco.com
    Blog: http://www.vnpro.org/blog

  7. #7

    Default

    Cảm ơn anh. Em đọc qua và đã cấu hình trên switch 2960 nhưng có một số cái không hiểu. Mong anh chỉ giúp em, anh có thể cho em địa chỉ email của anh để em gởi file cấu hình qua cho a xem được không anh!

    version 12.2
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    !
    hostname HL-HCM-SW
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret 5 $1$6u3x$aDGgNCazMh.6K4Q3huAvY/
    .
    .
    .
    .
    .
    .
    .
    aaa new-model
    !
    !
    aaa authentication dot1x default group radius
    aaa authorization network default group radius
    !
    !
    !
    aaa session-id common
    system mtu routing 1500
    ip subnet-zero.
    .
    .
    .
    .
    .
    .
    interface FastEthernet0/18
    switchport access vlan 4
    switchport mode access
    authentication host-mode multi-auth
    authentication port-control auto
    authentication violation restrict
    mab eap
    dot1x pae authenticator
    dot1x timeout tx-period 1
    dot1x max-reauth-req 1
    .
    .
    .
    .
    .
    interface FastEthernet0/22
    description ACSNet-SVR
    switchport access vlan 80
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet0/23
    switchport access vlan 101
    switchport mode access
    !
    interface FastEthernet0/24
    switchport access vlan 101
    switchport mode access
    spanning-tree portfast
    !
    interface GigabitEthernet0/1
    description Connect-to-FPT Zyxel
    switchport trunk allowed vlan 3,4,80,101
    switchport mode trunk
    !
    interface GigabitEthernet0/2
    switchport mode trunk
    .
    .
    .
    .
    interface Vlan80
    ip address 192.168.10.10 255.255.255.0
    no ip route-cache
    !
    ip default-gateway 192.168.10.1
    ip http server
    ip http secure-server
    snmp-server community HL-SNMP RO
    radius-server host 192.168.10.2 auth-port 1645 acct-port 1646 key 7 060E00204242061702
    .
    .
    .
    .
    - em cấu hình xong nhưng khi cắm dây trực tiếp từ modem ADSL ( 192.168.10.1 ) vào cổng GigabitEthernet0/2
    - Từ Switch em ping 192.168.10.1 lại không thấy!!!!
    - Em cắm dây từ server ACS ( 192.168.10.2 ) vào cổng FastEthernet0/22
    - Từ Switch em ping 192.168.10.2 thì thấy nhưng không ping được 192.168.10.1!!! nên cắm dây từ client vào cổng FastEthernet0/18 trên switch báo không chứng thực được.
    - Mong anh chỉ dùm em cách khắc phục
    - Cảm ơn anh rất nhiều!
    Last edited by oliverken00; 17-04-2012 at 08:21 PM.

  8. #8
    Join Date
    Aug 2008
    Location
    VnPro
    Posts
    1,154

    Default

    Bạn gởi giúp mình một topology bổ sung nhé.
    Phan Hoàng Gia Liêm - Instructor
    Email : gialiem@vnpro.org
    Yahoo : gialiem_vnpro
    -----------------------------------------------------------------------------------------------
    Trung Tâm Tin Học VnPro
    149/1D Ung Văn Khiêm P25 Q.Bình thạnh TPHCM
    Tel : (08) 35124257 (5 lines)
    Fax: (08) 35124314

    Home page: http://www.vnpro.vn
    Support Forum: http://www.vnpro.org
    - Chuyên đào tạo quản trị mạng và hạ tầng Internet
    - Phát hành sách chuyên môn
    - Tư vấn và tuyển dụng nhân sự IT
    - Tư vấn thiết kế và hỗ trợ kỹ thuật hệ thống mạng

    Network channel: http://www.dancisco.com
    Blog: http://www.vnpro.org/blog

  9. #9

    Default

    Quote Originally Posted by hoanggialiem View Post
    Bạn gởi giúp mình một topology bổ sung nhé.

    Em gởi anh topology, a xem giúp em nhé.
    topology.jpg
    Last edited by oliverken00; 20-04-2012 at 11:40 PM.

  10. #10

    Default

    Quote Originally Posted by hoanggialiem View Post
    Bạn gởi giúp mình một topology bổ sung nhé.
    Em gởi cho anh topology roi do anh. Anh xem giup em với.!!!
    Cảm ơn anh!

    topology.jpg
    Last edited by oliverken00; 19-04-2012 at 11:16 PM.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Website game điện thoại: Game Bigone , iwin