• If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.
Xin chào ! Nếu đây là lần đầu tiên bạn đến với diễn đàn, xin vui lòng danh ra một phút bấm vào đây để đăng kí và tham gia thảo luận cùng VnPro.

Announcement

Collapse
No announcement yet.

MPLS Lab

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • MPLS Lab

    Chào mọi người,

    Mình có mô hình lab như hình vẽ. Mình chạy bằng Dynamips, cấu hình như sau:
    en
    conf t
    host P1-AS1
    !
    int lo0
    ip add 10.10.10.200 255.255.255.255
    !
    int s1/0
    ip add 10.10.10.2 255.255.255.252
    no shut
    mpls ip
    !
    int s1/1
    ip add 10.10.10.6 255.255.255.252
    no shut
    mpls ip
    !
    router ospf 1
    log-adjacency-changes
    network 10.0.0.0 0.255.255.255 area 0

    *************************************************


    en
    conf t
    host PE1-AS1
    !
    ip vrf CustA
    rd 1:100
    route-target export 1:100
    route-target import 1:100
    !
    int lo0
    description RID for MP-BGP
    ip add 10.10.10.101 255.255.255.255
    !
    int s1/0
    description connected to P1-As1
    ip add 10.10.10.1 255.255.255.252
    no shut
    mpls ip
    !
    int s1/1
    description connected to CE1-A
    ip vrf forwarding CustA
    ip add 172.16.1.1 255.255.255.252
    no shut
    !
    router eigrp 1
    no auto-summary
    !
    address-family ipv4 vrf CustA
    redistribute bgp 1 metric 1000 100 255 1 1500
    network 172.16.0.0
    no auto-summary
    autonomous-system 101
    exit-address-family
    !
    router ospf 1
    router-id 10.10.10.101
    log-adjacency-changes
    network 10.0.0.0 0.255.255.255 area 0
    !
    router bgp 1
    no synchronization
    bgp log-neighbor-changes
    neighbor 10.10.10.102 remote-as 1
    neighbor 10.10.10.102 update-source Loopback0
    no auto-summary
    !
    address-family vpnv4
    neighbor 10.10.10.102 activate
    neighbor 10.10.10.102 send-community both
    exit-address-family
    !
    address-family ipv4 vrf CustA
    redistribute eigrp 101
    no auto-summary
    no synchronization
    exit-address-family
    !
    *************************************************
    en
    conf t
    host PE2-AS1
    !
    ip vrf CustA
    rd 1:100
    route-target export 1:100
    route-target import 1:100
    !
    int lo0
    description RID for MP-BGP
    ip add 10.10.10.102 255.255.255.255
    !
    int s1/0
    description connected to P1-AS1
    ip add 10.10.10.5 255.255.255.252
    no shut
    mpls ip
    !
    int s1/1
    description connected to PE2-A
    ip vrf forwarding CustA
    ip add 172.16.2.1 255.255.255.252
    no shut
    !
    router eigrp 1
    auto-summary
    !
    address-family ipv4 vrf CustA
    redistribute bgp 1 metric 1000 100 255 1 1500
    network 172.16.0.0
    no auto-summary
    autonomous-system 101
    exit-address-family
    !
    router ospf 1
    router-id 10.10.10.102
    log-adjacency-changes
    network 10.0.0.0 0.255.255.255 area 0
    !
    router bgp 1
    no synchronization
    bgp log-neighbor-changes
    neighbor 10.10.10.101 remote-as 1
    neighbor 10.10.10.101 update-source Loopback0
    no auto-summary
    !
    address-family vpnv4
    neighbor 10.10.10.101 activate
    neighbor 10.10.10.101 send-community both
    exit-address-family
    !
    address-family ipv4 vrf CustA
    redistribute eigrp 101
    no auto-summary
    no synchronization
    exit-address-family
    !
    *************************************************
    en
    conf t
    host CE1-A
    !
    int fa0/0
    ip add 172.16.10.1 255.255.255.0
    no shut
    no keepalive
    !
    int s1/0
    description connected to PE1-AS1
    ip add 172.16.1.2 255.255.255.252
    no shut
    !
    router eigrp 101
    network 172.16.0.0
    no auto-summary
    *************************************************
    en
    conf t
    host CE2-A
    !
    int lo0
    ip add 172.16.99.1 255.255.255.0
    !
    int fa0/0
    ip add 172.16.20.1 255.255.255.0
    no shut
    no keepalive
    !
    int s1/0
    description connected to PE2-AS1
    ip add 172.16.2.2 255.255.255.252
    no shut
    !
    router eigrp 101
    redistribute ospf 101
    passive-interface Loopback0
    network 172.16.0.0
    no auto-summary
    !
    router ospf 101
    log-adjacency-changes
    redistribute eigrp 101 subnets
    network 172.16.99.0 0.0.0.255 area 0


    Sau khi đã cấu hình xong, show ip route trên các CE cho kết quả:
    CE1-A#sho ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route

    Gateway of last resort is not set

    172.16.0.0/16 is variably subnetted, 5 subnets, 2 masks
    D 172.16.20.0/24 [90/2684416] via 172.16.1.1, 00:10:11, Serial1/0
    C 172.16.10.0/24 is directly connected, FastEthernet0/0
    C 172.16.1.0/30 is directly connected, Serial1/0
    D 172.16.2.0/30 [90/2681856] via 172.16.1.1, 00:10:11, Serial1/0
    D 172.16.99.0/24 [90/2809856] via 172.16.1.1, 00:10:11, Serial1/0

    CE2-A#sho ip rou
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route

    Gateway of last resort is not set

    172.16.0.0/16 is variably subnetted, 5 subnets, 2 masks
    C 172.16.20.0/24 is directly connected, FastEthernet0/0
    D 172.16.10.0/24 [90/2684416] via 172.16.2.1, 00:10:14, Serial1/0
    D 172.16.1.0/30 [90/2681856] via 172.16.2.1, 00:10:14, Serial1/0
    C 172.16.2.0/30 is directly connected, Serial1/0
    C 172.16.99.0/24 is directly connected, Loopback0

    Tuy nhiên CE1-A không ping được CE2-A
    CE1-A#ping 172.16.2.2

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 172.16.2.2, timeout is 2 seconds:
    .....
    Success rate is 0 percent (0/5)

    Mình thử traceroute thì thấy packet bị kẹt trên PE1-As1
    CE1-A#traceroute 172.16.2.2

    Type escape sequence to abort.
    Tracing the route to 172.16.2.2

    1 172.16.1.1 64 msec 100 msec 104 msec
    2 * * *
    3 * * *

    Cả hai PE1 & PE2 đều ping được tới các CE của nó:
    PE1-AS1#ping vrf CustA 172.16.10.1

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 172.16.10.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 52/74/128 ms

    PE2-AS1#ping vrf CustA 172.16.20.1

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 172.16.20.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 28/55/108 ms

    Tuy nhiên các lệnh show trên PE1-As1 và PE2-AS1 cho thấy cả 2 PE đều đã học đuợc route của nhau.
    PE1-AS1#ping 10.10.10.102[/B]

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.10.10.102, timeout is 2 seconds:
    !!!!!
    ----------------------------------------------------------------------------
    Success rate is 100 percent (5/5), round-trip min/avg/max = 56/88/128 ms
    PE1-AS1#sho ip rout vrf CustA

    Routing Table: CustA
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route

    Gateway of last resort is not set

    172.16.0.0/16 is variably subnetted, 5 subnets, 2 masks
    B 172.16.20.0/24 [200/2172416] via 10.10.10.102, 00:14:54
    D 172.16.10.0/24 [90/2172416] via 172.16.1.2, 00:15:45, Serial1/1
    C 172.16.1.0/30 is directly connected, Serial1/1
    B 172.16.2.0/30 [200/0] via 10.10.10.102, 00:14:54
    B 172.16.99.0/24 [200/2297856] via 10.10.10.102, 00:14:54

    PE2-AS1#sho ip rout vrf CustA

    Routing Table: CustA
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route

    Gateway of last resort is not set

    172.16.0.0/16 is variably subnetted, 5 subnets, 2 masks
    D 172.16.20.0/24 [90/2172416] via 172.16.2.2, 00:15:52, Serial1/1
    B 172.16.10.0/24 [200/2172416] via 10.10.10.101, 00:14:59
    B 172.16.1.0/30 [200/0] via 10.10.10.101, 00:14:59
    C 172.16.2.0/30 is directly connected, Serial1/1
    D 172.16.99.0/24 [90/2297856] via 172.16.2.2, 00:15:52, Serial1/1

    ----------------------------------------------------------------------------
    PE1-AS1#sho ip bgp vpnv4 vrf CustA
    BGP table version is 11, local router ID is 192.168.101.1
    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
    r RIB-failure, S Stale
    Origin codes: i - IGP, e - EGP, ? - incomplete

    Network Next Hop Metric LocPrf Weight Path
    Route Distinguisher: 1:100 (default for vrf CustA)
    *> 172.16.1.0/30 0.0.0.0 0 32768 ?
    *>i172.16.2.0/30 10.10.10.102 0 100 0 ?
    *> 172.16.10.0/24 172.16.1.2 2172416 32768 ?
    *>i172.16.20.0/24 10.10.10.102 2172416 100 0 ?
    *>i172.16.99.0/24 10.10.10.102 2297856 100 0 ?

    PE2-AS1#sho ip bgp vpnv4 vrf CustA
    BGP table version is 11, local router ID is 192.168.102.1
    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
    r RIB-failure, S Stale
    Origin codes: i - IGP, e - EGP, ? - incomplete

    Network Next Hop Metric LocPrf Weight Path
    Route Distinguisher: 1:100 (default for vrf CustA)
    *>i172.16.1.0/30 10.10.10.101 0 100 0 ?
    *> 172.16.2.0/30 0.0.0.0 0 32768 ?
    *>i172.16.10.0/24 10.10.10.101 2172416 100 0 ?
    *> 172.16.20.0/24 172.16.2.2 2172416 32768 ?
    *> 172.16.99.0/24 172.16.2.2 2297856 32768 ?

    Nhờ các bạn troubleshoot giúp. Thanks
    Attached Files
    Last edited by rintrum; 26-10-2007, 01:15 PM.
    CCIE#24929 (SP)
    Networking Forum: http://netspace.vn/forum

  • #2
    Ban co cau hinh "ip cef" tren tat ca cac router chua?
    Trần Nhân Hòa
    CMND #0146257668

    Comment

    Working...
    X