Results 1 to 8 of 8

Thread: XÂY DỰNG HỆ THỐNG VoIP

  1. #1
    Join Date
    Aug 2007
    Location
    Hồ Chí Minh
    Posts
    101

    Default XÂY DỰNG HỆ THỐNG VoIP

    Sơ đồ hệ thống



    Mục đích:

    1 Cấu hình cuộc gọi giữa hai điện thoại analog.
    2 Cấu hình cuộc gọi giữa hai softphone cùng site hoặc khác site.
    3 Cấu hình cuộc gọi giữa softphone và analog.

    Yêu cầu phần mềm:

    +SIP Server:Ở đây sử dụng SIP server bằng phần mềm Brekeke SIP Server(download tại địa chỉ:www.brekeke.com).
    +Client:Sử dụng softphone là X-Lite(Có thể download tại trang:www.couterpath.com).


    Cài đặt các phần mềm

    Cài đặt softphone X-Lite client
    Sau khi tải chương trình về cài đặt chương trình
    Bạn cần khởi động lại máy để hoàn tất cài đặt.

    Sau khi cài đặt hoàn thành X-Lite có giao diện:



    Cài đặt SIP Server

    Sau khi tải SIP server về địa chỉ www.brekeke.com,chạy file setup cài SIP server.

    Cấu hình cho các router

    +Cấu hình cho Router 1

    Code:
    !
    !
    interface Ethernet0/0
     ip address 10.215.219.254 255.255.255.0
     half-duplex
    !
    interface Serial0/0
     bandwidth 256
     ip address 192.168.1.1 255.255.255.0
     clock rate 64000
     no fair-queue
    !
    interface ATM0/1
     no ip address
     shutdown
     no atm ilmi-keepalive
     dsl operating-mode auto
    !
    ip http server
    no ip http secure-server
    ip classless
    ip route 0.0.0.0 0.0.0.0 192.168.1.2
    !
    !
    !
    !
    voice-port 1/1/0
    !
    voice-port 1/1/1
    !
    !
    dial-peer cor custom
    !
    !
    !
    dial-peer voice 1 pots
     destination-pattern 201
     port 1/1/0
    !
    dial-peer voice 2 pots
     destination-pattern 301
     port 1/1/1
    !
    dial-peer voice 3 voip
     destination-pattern 301
     session target ipv4:192.168.1.2
    !
    dial-peer voice 4 voip
     destination-pattern 101
     session protocol sipv2
     session target ipv4:10.215.219.79     //Địa chỉ SIP Server
     codec g711alaw
    !
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    !
    !
    End
    +Cấu hình cho Router 2

    --More--
    Code:
    !
    interface Ethernet0/0
     ip address 10.215.219.254 255.255.255.0
     half-duplex
    !
    interface Serial0/0
     bandwidth 256
     ip address 192.168.1.2 255.255.255.0
    !
    ip http server
    no ip http secure-server
    ip classless
    ip route 0.0.0.0 0.0.0.0 192.168.1.1
    !
    !
    !
    !
    voice-port 1/0/0
    !
    voice-port 1/0/1
    !
    !
    !
    dial-peer voice 1 pots
     destination-pattern 301
     port 1/0/0
    !
    dial-peer voice 2 voip
     destination-pattern 201
    
     session target ipv4:192.168.1.1
    !
    dial-peer voice 3 voip
     destination-pattern 110
     session protocol sipv2
     session target ipv4:10.215.219.79 //Địa chỉ SIP Server
     codec g711alaw
    !
    dial-peer voice 4 pots
     destination-pattern 101
     port 1/0/1
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
     privilege level 15
     no login
    !
    !
    end
    4 Thực hiện cấu hình cuộc gọi

    Cấu hình cuộc gọi giữa hai softphone client

    -Tạo tài khoản người dùng

    Tài khoản người dùng có user name là số điện thoại được gán cho một người cụ thể.


    Hình 4.1.1a Màn hình tạo tài khoản người dùng

    Ở đây tạo 2 tài khoản có số điện thoại là 101 và 102.Sau khi tạo tài khoản xong có thể kiểm tra bằng cách click vào tab View User



    Hình 4.1.1b Kiểm tra tài khoản người dùng trong tabView Users

    +Thực hiện cuộc gọi giữa hai softphone
    Sau khi tài khoản người dùng được tạo thì bạn có thể đăng ký trên softphone client


    Sau khi đang ký thành công,tài khoản đã sẳn sang



    Hình 4.1.2a:Đăng ký tài khoản có user là 101 trên softphone client thành công.

    Sau khi đăng ký tài khoản xong bạn có thể thiết lập cuộc gọi giữa hai tài khoản người dùng bằng softphone client.Ờ đây sử dụng user 101 để gọi tới 102

    Hình 4.1.2b :Thiết lập cuộc gọi từ tài khoản 101 đến tài khoản 102.


    Hình 4.1.2c Đang gọi tới tài khoản 102

    Hình 4.1.2e :Cuộc gọi từ 101 đi vào 102.
    Kết quả hiển thị khi thực hiện cuộc gọi trong Active Session từ số 101 đến 102

    -Cấu hình cuộc gọi giữa hai điện thoại analog,hoặc giữa softphone và điện thoại analog

    Muốn thực hiện cuộc gọi giữa hai điện thoại khác site hoặc giữa softphone và điện thoại analog thì cần phải tạo các rule trong dial-plan đế có thể thực hiện được các việc trên.
    Màn hình tạo rule.


    Hình 4.1.1b Kiểm tra tài khoản người dùng trong tabView Users
    -Thực hiện cuộc gọi giữa hai softphone

    Sau khi tài khoản người dùng được tạo thì bạn có thể đăng ký trên softphone client


    Ở đây tạo 2 rule có tên là Rule 1 và Rule 3.
    Sau khi tạo rule xong có thể kiểm tra lại trong tab View Rules



    Hình thể hiện các rule vừa tạo trong dial-plan
    Last edited by tranthanhliem; 25-09-2007 at 01:44 PM.
    tranthanhliem@vnpro.org
    Trung tâm tin học VnPro
    Viet Professional Ltd. Co
    Cisco Authorised Training
    149/1D Ung Văn Khiêm P25 Q.Bình thạnh TPHCM
    Tel: (08) 5124257-5125314
    Fax: (08) 5124314
    Website: http://vnpro.vn
    Support forum: http://vnpro.org

  2. #2

    Default

    Bạn cò thể post lại sơ đồ hệ thống dùm mình dc ko . Hình ở trên mình ko thấy hết dc
    Cảm ơn bạn

  3. #3

    Default cai SIP server no doi JAVA virtual Machin ... tim o dau ban

    Quote Originally Posted by changia View Post
    Bạn cò thể post lại sơ đồ hệ thống dùm mình dc ko . Hình ở trên mình ko thấy hết dc
    Cảm ơn bạn
    cai SIP server no doi JAVA virtual Machin ... tim o dau ban

  4. #4

    Default

    Chào các bác :

    Có bác nào đã ứng dụng tính năng FAX qua VoIP của tổng đài Asterisk chưa ? Tui đã thử dùng Hylafax và Ĩamodem nhưng không đạt hiệu quả.
    Bác nào đã dùng được tính năng này thì cho học hỏi kiến thức với nhé.

    Chân thành cám ơn

  5. #5

    Default

    sao minh nhap cac lenh cau hinh routet vo ma no ko hieu vay, chac la IOS khong dung ha? minh dung con 2600 ay. vay phai lam sao day?

  6. #6
    cacodemon Guest

    Default

    theo bạn nếu mình muốn triển khai hệ thống voice ip tại 2 site thì chi phí khoảng bao nhiêu?

  7. #7
    vuquanghienbn Guest

    Default

    www.couterpath.com

    Cái này có mấy phần để down cơ. không biết là chòn phần nào

  8. #8

    Default

    chào, các bạn :

    Bạn nào cần phần mềm X-lite, EDfisk, Ekiga cho các cuộc gọi SIP và IAX2, hoặc muốn tìm hiều về Asterisk, các thiết bị VoIP : IP Phone, Gateway, ATA thì có thể tham khảo các trang Web dưới đây nhé :

    1, http://www.voip.com.vn
    2, http://atcom.cn/En_products.html
    3, http://www.voip-info.org
    4, http://www.soundwin.com

    Lê Thanh Hiếu
    Kỹ sư VoIP
    Phone : 0908 966 159

Similar Threads

  1. Các kế hoạch bảo mật đối với hệ thống VOIP
    By danghoangkhanh in forum Voice & Video
    Replies: 4
    Last Post: 13-03-2012, 04:14 PM
  2. Các Mối đe Dọa đối Với Hệ Thống Voip
    By danghoangkhanh in forum Voice & Video
    Replies: 2
    Last Post: 19-06-2008, 09:44 AM
  3. Replies: 2
    Last Post: 27-01-2004, 01:49 PM
  4. Truy xuất qua vệ tinh
    By quoc_anh in forum Metro, MPLS, Optical Networking, Storage Networking
    Replies: 3
    Last Post: 30-09-2003, 11:08 AM
  5. Project về xậy dựng 1 hệ thống mạng LAN đơn giản
    By lknhan in forum Các website và sách hữu ích cho việc học networking
    Replies: 2
    Last Post: 27-08-2003, 10:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •