Results 1 to 3 of 3

Thread: LAB 3-9: RIP và Discontiguous Networks (with file .net)

  1. #1

    Default LAB 3-9: RIP và Discontiguous Networks (with file .net)

    Nguồn: Sách CCNA Labpro

    LAB 3-9: RIP & DISCONTIGUOUS NETWORKS


    Mô tả:
    - Router R1, R2 sử dụng RIP để quảng bá thông tin định tuyến.
    - Router R1 hoạt động như DCE cung cấp xung clock cho R2.
    - Từ Router R1, R2 ping được các địa chỉ trong mạng.

    Chú ý: Discontiguous network là mạng bao gồm nhiều mạng con thuộc cùng một mạng chính (major network) bị phân cách bởi một mạng khác. ví dụ như hình trên, mạng con 130.1.1.0/24 trên router R1 được phân cách với mạng 130.1.2.0/24 ở R2 bởi mạng 10.1.1.0

    Cấu hình:
    Router R1:
    hostname R1
    !
    enable password vnpro
    !
    ip subnet-zero
    no ip domain-lookup
    !
    interface Ethernet0
    ip address 130.1.1.1 255.255.255.0
    no keepalive
    !
    interface Serial0
    ip address 10.1.1.1 255.255.255.0
    clock rate 64000
    !
    router rip
    network 130.1.0.0
    network 10.0.0.0
    !
    end

    Router R2:
    hostname R2
    !
    enable password vnpro
    !
    ip subnet-zero
    no ip domain-lookup
    !
    interface Ethernet0
    ip address 130.1.2.1 255.255.255.0
    no keepalive
    !
    interface Serial0
    ip address 10.1.1.2 255.255.255.0
    !
    router rip
    network 130.1.0.0
    network 10.0.0.0
    !
    end

    Các bước thự hiện:
    1. Đặt hostname, cấu hình cho loopback, ethernet và serial trên router R1.
    Router> en
    Router# conf t
    Router(config)# hostname R1
    R1(config)# no ip domain-lookup
    R1(config)# int e0
    R1(config-if)# ip addr 130.1.1.1 255.255.255.0
    R1(config-if)# no keepalive <- cho phép cổng Ethernet vẫn up khi không kết nối với bên ngoài
    R1(config-if)# no shut
    %LINK-3-UPDOWN: Interface Ethernet0, changed state to up
    %LINK-5-UPDOWN: Line protocol on Interface Ethernet0, changed state to up
    R1(config-if)# exit

    R1(config)# int s0
    R1(config-if)# ip addr 10.1.1.1 255.255.255.0
    R1(config-if)# clock rate 64000 <- hoạt động như DCE cung cấp xung clock
    R1(config-if)# no shut

    2. Đặt hostname, cấu hình cho cổng loopback, ethernet và serial trên router R2.
    Router> en
    Router# conf t
    Router(config)# hostname R2
    R2(config)# no ip domain-lookup

    R2(config)#int e0
    R2(config-if)# ip addr 130.1.2.1 255.255.255.0
    R1(config-if)# no keepalive
    R2(config-if)# no shut

    R2(config-if)# int s0
    R2(config-if)# ip addr 10.1.1.2 255.255.255.0
    R2(config-if)# no shut

    3. Cấu hình giao thức định tuyến RIP trên router R1, R2 và lưu cấu hình lên NVRAM.
    R1(config)# router rip <- kích hoạt quá trình định tuyến RIP trên router
    R1(config-router)# network 130.1.0.0 <- chỉ ra mạng nào sẽ chạy RIP
    R1(config-router)# network 10.0.0.0
    R1(config-router)# end
    R1# copy run start

    R2(config)# router rip
    R2(config-router)# network 130.1.0.0
    R2(config-router)# network 10.0.0.0
    R2(config-rputer)# end
    R2# copy run start

    Kiểm tra và giải quyết sự cố:
    - Xem quá trình gửi nhận thông tin định tuyến RIP bằng lệnh debug ip rip
    R2#debug ip rip
    R2#
    00:12:19: RIP: received v1 update from 10.1.1.1 on Serial0
    00:12:19: 130.1.0.0 in 1 hops

    - Tắt chế độ debug bằng lệnh undebug all hoặc viết gọn là u all
    R2# u all
    All possible debugging has been turned off

    - Xem bảng định tuyến trên R2 bằng lệnh show ip route
    R2# show ip route
    Gateway of last resort is not set
    130.1.0.0/24 is subnetted, 1 subnets
    C 130.1.2.0 is directly connected, Ethernet0
    10.0.0.0/24 is subnetted, 1 subnets
    C 10.1.1.0 is directly connected, Serial0
    R2#

    - Ta thấy trên R2 không có mạng 130.1.1.0 trong bảng định tuyến. Lý do là RIP chỉ hỗ trợ classfull nên không gửi đi thông tin về subnet mask trong các routing update. Khi R1 gửi thông tin về mạng 130.1.1.0 đến R2, R1 sẽ thực hiện summary mạng này về dạng classfull – 130.1.0.0. R2 kết nối trực tiếp với 130.1.2.0 thì sẽ hiểu mạng này là 130.1.0.0. Do đó, khi R2 nhận thông tin về mạng 130.1.0.0, nó sẽ loại bản tin update này vì mạng này đã có trong bảng định tuyến với metric cao hơn.
    - Để giải quyết vấn đề này ta sử dụng địa chỉ secondary trên cổng kết nối giữa R1 và R2, địa chỉ này phải thuộc major network trong mạng discontiguous network và phải cùng subnetmask.
    R1(config)# int s0
    R1(config-if)# ip address 130.1.3.1 255.255.255.0 secondary

    R2(config)#int s0
    R2(config-if)# ip address 130.1.3.2 255.255.255.0 secondary

    - Dùng lệnh clear ip route * để xóa toàn bộ route từ bảng định tuyến.
    R1# clear ip route *

    - Xem quá trình gửi nhận thông tin định tuyến RIP bằng lệnh debug ip rip . Chú ý rằng R2 bây giờ nhận update về mạng 131.1.1.0 từ R1.
    R2#debug ip rip
    R2#
    00:15:10: RIP: received v1 update from 130.1.3.1 on Serial0
    00:15:10: 130.1.1.0 in 1 hops

    - Xem bảng định tuyến trên R2 bằng lệnh show ip route
    R2# show ip route
    Gateway of last resort is not set
    130.1.0.0/24 is subnetted, 4 subnets
    C 130.1.3.0 is directly connected, Serial0
    C 130.1.2.0 is directly connected, Ethernet0
    R 130.1.1.0[120/1] via 130.1.3.1, 00:00:25, Serial0
    R 130.1.0.0 [120/1] via 10.1.1.1, 00:00:25, Serial0
    10.0.0.0/24 is subnetted, 2 subnets
    R 10.1.0.0 [120/1] via 130.1.3.1, 00:00:25, Serial0
    C 10.1.1.0 is directly connected, Serial0
    R2#

  2. #2

    Default

    Sao không thấy hình vậy?, mà đa số các link trong bài viết đều die , ai ơi giúp với.

  3. #3

    Default

    Nhi`n cau hinh vay chac day la cai hi`nh

    [PC1]----e0[R1]s0-----s0[R2]e0----[PC2]

Similar Threads

  1. File .net
    By linh2t in forum ICND 2 - Routing & Access-list
    Replies: 2
    Last Post: 13-03-2009, 03:22 PM
  2. Các comand trong console ???
    By mykenty in forum Unix
    Replies: 4
    Last Post: 21-03-2004, 06:37 PM
  3. Hoi ve Gopher
    By hvviet2000 in forum Microsoft
    Replies: 2
    Last Post: 17-12-2003, 01:12 PM
  4. FTP LÀ GÌ?
    By itworld in forum WAN & Remote Access
    Replies: 3
    Last Post: 17-11-2003, 01:04 PM
  5. Show version Trên Switch
    By leminhkhoi in forum SWITCH / BCMSN
    Replies: 4
    Last Post: 31-10-2003, 03:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Website game điện thoại:Bigone