• If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.
Xin chào ! Nếu đây là lần đầu tiên bạn đến với diễn đàn, xin vui lòng danh ra một phút bấm vào đây để đăng kí và tham gia thảo luận cùng VnPro.

Announcement

Collapse
No announcement yet.

Cấu hình Inter VLAN routing với switch layer 3

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cấu hình Inter VLAN routing với switch layer 3

    - bài lab mô tả cách giả lập switch layer 3 trên Dynagen và cấu hình InterVLAN routing:

    - cấu hình file .net :

    #simulate Layer 3 switch
    #Inter VLAN routing

    [localhost]

    [[3640]]
    image = D:\dynagenlabs\images\c3640-jk9o3s-mz.123-14.T7.extracted.bin
    ram = 256
    mmap = true
    ghostios = true
    sparsemem = true

    #switch SW1
    [[Router SW1]]
    model = 3640
    console = 2002
    slot 1 = NM-16ESW
    idlepc = 0x8000ba50
    fa1/3 = NIO_udp:30000:127.0.0.1:20000
    fa1/4 = NIO_udp:30001:127.0.0.1:20001

    #switch SW2
    [[Router SW2]]
    model = 3640
    console = 2003
    slot 1 = NM-16ESW
    idlepc = 0x8000becc
    fa1/3 = NIO_udp:30002:127.0.0.1:20002
    fa1/4 = NIO_udp:30003:127.0.0.1:20003

    #switch layer 3
    [[Router SWL3]]
    model = 3640
    console = 2004
    slot 0 = NM-16ESW
    #idlepc = 0x60566918
    f0/1 = SW1 fa1/0
    f0/2 = SW2 fa1/0
    - cấu hình của các virtual pc:

    # The startup file of VPC
    #
    1
    ip 192.168.2.10 192.168.2.1 24
    # switch to PC1
    1
    2
    ip 192.168.2.20 192.168.2.1 24
    # switch to PC2
    2
    3
    ip 192.168.3.10 192.168.3.1 24
    # switch to PC1
    3
    4
    ip 192.168.3.20 192.168.3.1 24
    # switch to PC2
    4
    - cấu hình Switch L3:

    Router(config)#hostname SWL3
    SWL3(config)#ip routing
    SWL3(config)#int range fa 0/1 - 2
    SWL3(config-if-range)#switchport trunk encapsulation dot1q
    SWL3(config-if-range)#switchport mode trunk
    SWL3(config-if-range)#exit
    SWL3(config)#int vlan 2
    SWL3(config-if)#ip address 192.168.2.1 255.255.255.0
    SWL3(config-if)#no shut
    SWL3(config)#int vlan 3
    SWL3(config-if)#ip address 192.168.3.1 255.255.255.0
    SWL3(config-if)#no shut
    SWL3(config-if)#int loopback 0
    SWL3(config-if)#ip address 10.0.0.1 255.255.255.0
    SWL3(config-if)#end
    SWL3#vlan database
    SWL3(vlan)#vtp server
    SWL3(vlan)#vtp domain cisco
    SWL3(vlan)#vlan 2 name group02
    SWL3(vlan)#vlan 3 name group03
    SWL3(vlan)#exit
    SWL3#

    - cấu hình SW1:

    Router(config)#hostname SW1
    SW1(config)#no ip routing
    SW1#vlan database
    SW1(vlan)#vtp client
    SW1(vlan)#vtp domain cisco
    SW1(vlan)#exit
    SW1#conf t
    SW1(config)#int fa1/0
    SW1(config-if)#switchport trunk encapsulation dot1q
    SW1(config-if)#switchport mode trunk
    SW1(config-if)#exit
    SW1(config)#int range fa 1/3 - 4
    SW1(config-if-range)#switchport mode access
    SW1(config-if-range)#switchport access vlan 2
    SW1(config-if-range)#end

    - cấu hình SW2

    Router(config)#hostname SW2
    SW2(config)#no ip routing
    SW2#vlan database
    SW2(vlan)#vtp client
    SW2(vlan)#vtp domain cisco
    SW2(vlan)#exit
    SW2#conf t
    SW2(config)#int fa1/0
    SW2(config-if)#switchport trunk encapsulation dot1q
    SW2(config-if)#switchport mode trunk
    SW2(config-if)#exit
    SW2(config)#int range fa 1/3 - 4
    SW2(config-if-range)#switchport mode access
    SW2(config-if-range)#switchport access vlan 3
    SW2(config-if-range)#end

    - ktra lại lab : từ các virtual pc ở vlan 2 ping đến các virtual pc ở vlan 3 và ping được đến địa chỉ ip 10.0.0.1 của interface loopback 0 trên SWL3.
    no car...no house...no money, but have only a sharing and friendly heart. What's the most important thing in this life "Heart or Money ?". Anything else can stead money ?

    :32::53::X:106:

    Nothing last forever...

  • #2
    chao anh

    Anh co the chi ro~ cach tao VPC dc ko em ko hieu doan.
    # The startup file of VPC
    #
    1
    ip 192.168.2.10 192.168.2.1 24
    # switch to PC1
    1
    2
    ip 192.168.2.20 192.168.2.1 24
    # switch to PC2
    2
    3
    ip 192.168.3.10 192.168.3.1 24
    # switch to PC1
    3
    4
    ip 192.168.3.20 192.168.3.1 24
    # switch to PC2
    4
    .co fai doan tren danh trong file .NET lun ha~ anh???xin chi em:(

    Comment


    • #3
      Originally posted by trainingit View Post
      - bài lab mô tả cách giả lập switch layer 3 trên Dynagen và cấu hình InterVLAN routing:

      - cấu hình file .net :



      - cấu hình của các virtual pc:



      - cấu hình Switch L3:

      Router(config)#hostname SWL3
      SWL3(config)#ip routing
      SWL3(config)#int range fa 0/1 - 2
      SWL3(config-if-range)#switchport trunk encapsulation dot1q
      SWL3(config-if-range)#switchport mode trunk
      SWL3(config-if-range)#exit
      SWL3(config)#int vlan 2
      SWL3(config-if)#ip address 192.168.2.1 255.255.255.0
      SWL3(config-if)#no shut
      SWL3(config)#int vlan 3
      SWL3(config-if)#ip address 192.168.3.1 255.255.255.0
      SWL3(config-if)#no shut
      SWL3(config-if)#int loopback 0
      SWL3(config-if)#ip address 10.0.0.1 255.255.255.0
      SWL3(config-if)#end
      SWL3#vlan database
      SWL3(vlan)#vtp server
      SWL3(vlan)#vtp domain cisco
      SWL3(vlan)#vlan 2 name group02
      SWL3(vlan)#vlan 3 name group03
      SWL3(vlan)#exit
      SWL3#

      - cấu hình SW1:

      Router(config)#hostname SW1
      SW1(config)#no ip routing
      SW1#vlan database
      SW1(vlan)#vtp client
      SW1(vlan)#vtp domain cisco
      SW1(vlan)#exit
      SW1#conf t
      SW1(config)#int fa1/0
      SW1(config-if)#switchport trunk encapsulation dot1q
      SW1(config-if)#switchport mode trunk
      SW1(config-if)#exit
      SW1(config)#int range fa 1/3 - 4
      SW1(config-if-range)#switchport mode access
      SW1(config-if-range)#switchport access vlan 2
      SW1(config-if-range)#end

      - cấu hình SW2

      Router(config)#hostname SW2
      SW2(config)#no ip routing
      SW2#vlan database
      SW2(vlan)#vtp client
      SW2(vlan)#vtp domain cisco
      SW2(vlan)#exit
      SW2#conf t
      SW2(config)#int fa1/0
      SW2(config-if)#switchport trunk encapsulation dot1q
      SW2(config-if)#switchport mode trunk
      SW2(config-if)#exit
      SW2(config)#int range fa 1/3 - 4
      SW2(config-if-range)#switchport mode access
      SW2(config-if-range)#switchport access vlan 3
      SW2(config-if-range)#end

      - ktra lại lab : từ các virtual pc ở vlan 2 ping đến các virtual pc ở vlan 3 và ping được đến địa chỉ ip 10.0.0.1 của interface loopback 0 trên SWL3.
      Bạn ơi ! Cho mình xin link download OS của switch layer 3 được không?

      Comment


      • #4
        Originally posted by haytraloiem View Post
        Bạn ơi ! Cho mình xin link download OS của switch layer 3 được không?
        - hiện tại vẫn chưa hoàn toàn giả lập được switch layer 3, bạn có thể dùng IOS của router, sau đó thêm NM-16ESW để giả lập - nhưng còn rất nhiều cái không hỗ trợ

        - link down IOS (C3640):
        MediaFire is a simple to use free service that lets you put all your photos, documents, music, and video in a single place so you can access them anywhere and share them everywhere.


        - để giả lập switch L3, bạn xem thêm 2 link này:



        no car...no house...no money, but have only a sharing and friendly heart. What's the most important thing in this life "Heart or Money ?". Anything else can stead money ?

        :32::53::X:106:

        Nothing last forever...

        Comment


        • #5
          Originally posted by VinhNam1904 View Post
          Anh co the chi ro~ cach tao VPC dc ko em ko hieu doan.
          .co fai doan tren danh trong file .NET lun ha~ anh???xin chi em:(
          - đoạn đó là trong file startup.vpc (ko nằm trong file.net), dành cho cấu hình các virtual pc, bạn có thể tìm cái VPCS trong box các phần mềm mô phỏng về và kết nối nó vào switch hay router.
          no car...no house...no money, but have only a sharing and friendly heart. What's the most important thing in this life "Heart or Money ?". Anything else can stead money ?

          :32::53::X:106:

          Nothing last forever...

          Comment


          • #6
            Admin ơi cho em hỏi file.net để cấu hình lab isis đa vùng?

            Comment


            • #7
              Originally posted by nam View Post
              Admin ơi cho em hỏi file.net để cấu hình lab isis đa vùng?
              chào !!!


              Down file đính kèm

              Chúc bạn vui !!!
              Attached Files
              Trần Mỹ Phúc
              tranmyphuc@hotmail.com
              Hãy add nick để có thông tin đề thi mới nhất :tranmyphuc (Hỗ trợ tối đa cho các bạn tự học)

              Cisco Certs : CCNP (Passed TSHOOT 1000/1000)

              Juniper Certs :
              JNCIP-ENT & JNCIP-SEC
              INSTRUCTORS (No Fee) : CISCO (Professional) , JUNIPER (Professional) , Microsoft ...

              [version 4.0] Ôn tập CCNA


              Comment


              • #8
                [QUOTE=trainingit;82472]
                SW1(config-if)#switchport trunk encapsulation dot1q
                SW1(config-if)#switchport mode trunk
                hic hic
                t k go dc lệnh trên
                hok byt sao nua
                What will be , will be

                Comment


                • #9
                  Lâu lắm rồi không sài dynagen vì GNS tiện lợi hơn rất nhiều

                  Comment


                  • #10
                    sparsemem = true

                    bác cho em hỏi lệnh này dùng để làm j thế? Em tìm mọi thứ rồi ko thấy cái định nghĩa xác thực nào rõ ràng về nó cả :((

                    Comment

                    Working...
                    X