PDA

View Full Version : Part 08 - SRX Getting Started - OSPF



GreenNET
25-07-2011, 03:07 PM
Part 08 - SRX Getting Started - OSPF

Bài viết này mô tả làm sao để bật tính năng OSPF và cấu hình một mạng OSPF.

Mục tiêu bài viết:
Bật OSPF và cấu hình một mạng OSPF trên thiết bị SRX.

Cấu hình qua giao diện J-Web
Ví dụ sau đây sẽ hướng dẫn bật tính năng OSPF trên cổng ge-0/0/0.0 và lo0.0 và cấu hình một mạng OSPF.
1. Chọn Configure>Routing>OSPF.

2. Click Add.

3. Trong ô Area Id, nhập area theo đinh dạng 32-bit (ví dụ, 0.0.0.0)

4. Click vào tab Interfaces.

5. Chọn vào check box của cổng mà bạn muốn thêm vào area (ví dụ, ge-0/0/0.0).

6. Cũng có thể chọn vào check box để thêm cổng loopback (ví dụ, lo0.0) vào area.

7.Chọn cổng loopback, và click Edit. Giao diện Edit xuất hiện.

8. Phải chắc rằng tùy chọn Enable OSPF on this interface phải được chọn.

9. Để chỉ định một số địa chỉ trên một số cổng được quảng bá nhưng không chạy OSPF trên cổng đó (passive mode), chọn check box Don't run OSPF, but advertise it.

10. Click OK.

11. Nếu có vài cổng khác cũng sử dụng passive mode, chọn mỗi interface, và click Edit. Làm lại bước 8 đến 10 cho mỗi interface.

12. Trong ô Add Area, click OK.

13. Trong vùng OSPF Global Settings, click Edit. Hộp thoại Edit Global Settings sẽ xuất hiện.

14. Trong ô Router Id, nhập một địa chỉ IP được chọn làm ID (ví dụ, 192.168.1.2).

15. Click OK.

Tiếp theo, bạn phải chỉ đinh OSPF như là một giao thức được chấp nhận trên chiều vào của mạng cho mỗi interface co tham gia vào OSPF.

1. Chọn Configure>Security>Zones.

2. Click security zone mà bạn muốn thay đổi (ví dụ, trust).

3. Dưới mục Interfaces Configuration, chọn một interface trong zone mà được gắn với OSPF (ví dụ, ge-0/0/0.0), và click Edit.

4. Trong phần Host Inbound Traffic Option, dưới mục Protocols, chọn Allow Selected Protocols.

5. Trong mục Allowed Selected Protocols, chọn ospf, và click Add.
Click OK.

6. Để áp dụng những thay đổi bạn đã cấu hình, chọn Apply.

7. Làm lại những thủ tục này cho mỗi interface tham gia OSPF.

Nếu đã hoàn thành việc cấu hình thiết bị, click Commit để các cấu hình có hiệu lực.

Cấu hình qua giao diện CLI

1. Bật OSPF trên một interface. Trong ví dụ, OSPF được bật ge-0/0/0.0, và backbone area với ID 0.0.0.0 được tạo.
user@host# set protocols ospf area 0.0.0.0 interface ge-0/0/0.0

2. Cho phép gói tin OSPF đi tới một security zone. Trong ví dụ, OSPF được chỉ đinh như một giao thức đwọc chấp nhận theo chiều vào mạng.
user@host# set security zones security-zone trust interfaces ge-0/0/0.0 host-inbound-traffic protocols ospf

3. Bật OSPF trên một loopback interface. Trong ví dụ, 192.168.1.2/32 được phân cho lo0 interface, và OSPF được bật trên lo0.0 interface. Passive mode chỉ định một số địa chỉ trên một số cổng được quảng bá nhưng không chạy OSPF trên cổng đó.
user@host# set interfaces lo0 unit 0 family inet address 192.168.1.2/32
user@host# set protocols ospf area 0.0.0.0 interface lo0.0 passive

4. Chỉ định một router ID. Trong ví dụ, router ID là 192.168.1.2. Chỉ định một router ID (RID) duy nhất cho mỗi router trong OSPF database.
user@host# set routing-options router-id 192.168.1.2
5. Chỉ định những routes trên những interface được quảng bá, thêm interface vào OSPF area ở chế độ passive mode. Trong ví dụ, vlan.100 được thêm vào OSPF area 0.0.0.0 ở passive mode.
user@host# set protocols ospf area 0.0.0.0 interface vlan.100 passive

6. Nếu đã hoàn thành việc cấu hình thiết bị, gõ commit để các cấu hình có hiệu lực.

Kiểm tra
Để kiểm tra cấu hình OSPF, sử dụng lệnh sau:
user@host> show ospf neighbor
Address Interface State ID Pri Dead
10.222.2.2 ge-0/0/11.0 Full 192.168.36.1 128 36

Troubleshooting
Để troubleshoot lỗi OSPF, sử dụng lệnh traceoptions.

user@host# set protocols ospf traceoptions file ospf.debug size 5m files 5
user@host# set protocols ospf traceoptions flag all

Hiện các bài viết mới về SRX-Series đã được cập nhật khá đầy đủ tại http://greennet.vn/blog hoặc các bạn có thể xem gián tiếp ngay tại box này

---------------------------------
Written by AnhTT – June 2011
GreenNET Training Center
__________________
GreenNET | Trung Tâm Đào Tạo Juniper Networks tại HCM
Lầu 1, Tòa nhà Vietnam Mobile; 385C Nguyễn Trãi, P.Nguyễn Cư Trinh, Q.1, TP.HCM
Điện thoại: (+84) 08.39201959 | Fax: (+84) 08.39201958
Email: info@greennet.vn | Website: www.greennet.vn