PDA

View Full Version : Cách cấu hình tính năng AutoQoS – Enterprise



danghoangkhanh
09-10-2007, 09:14 AM
Cách cấu hình tính năng AutoQoS – Enterprise

a. Bật tính năng AutoQoS – Enterprise

Auto-Discovery sử dụng NBAR trong untrust mode hoặc DSCP trong trust mode để phát hiện các ứng dụng và giao thức trên mạng khi chúng rời interface, thu thập dữ liệu từ các traffic và thực hiện phân tích thống kê. Thông tin thu thập được sẽ dùng để xây dựng biểu mẫu AutoQoS. Những biểu mẫu này sẽ được dùng để tạo class-map và policy-map phù hợp. Để khởi động Auto-Discovery, dùng lệnh auto discovery qos.
Một số điều kiện tiên quyết khi sử dụng lệnh auto discovery qos:
Nếu interface hay subinterface có tốc độ bằng 768 kbps hoặc thấp hơn, phải cấu hình địa chỉ IP (primary hoặc secondary) cho interface/subinterface đó.
Đối với tất cả interface hay subinterface, phải cấu hình băng thông cho chúng bằng câu lệnh bandwidth. Băng thông được cấu hình phải dựa vào tốc độ thực của kết nối.
Đối với ATM PVC, phải cấu hình tốc độ bit biến đổi (variable bit rate – VBR) bằng cách sử dụng câu lệnh vbr-nrt hoặc câu lệnh vbr-rt; hoặc cấu hình tốc độ bit không đổi (constant bit rate – CBR) bằng lệnh cbr.
Các hạn chế khi sử dụng lệnh auto discovery qos
Lệnh auto discovery qos không được hỗ trợ trên subinterface.
Không được thay đổi băng thông của interface trước khi sử dụng lệnh auto discovery qos.
Gỡ bỏ tất cả các chính sách đã áp dụng trên interface.
Tóm tắt các bước thực hiện:
1. enable
2. configure terminal
3. interface type number
4. bandwidth kilobits
5. vbr-nrt output-pcr output-scr output-mbs [input-pcr] [input-scr] [input-mbs]
6. vbr-rt peak-rate average-rate burst
7. cbr rate
8. pvc [name] vpi/vci [ces | ilmi | qsaal | smds]
9. ip address ip-address mask [secondary]
10. frame-relay interface-dlci dlci [ietf | cisco] [voice-cir cir] [ppp virtual-template-name]
11. auto discovery qos [trust]
12. exit

Sử dụng lệnh show auto discovery qos để thể hiện những dữ liệu đã thu thập được. Nên xem các thống kê QoS trong policy đề nghị trước khi áp dụng policy map lên interface. Điều này cho phép tiếp tục giai đoạn Auto-Discovery hoặc copy và thay đổi policy.

b. Bật giai đoạn tạo biểu mẫu và cài đặt
Giai đoạn này tạo các biểu mẫu dựa vào dữ liệu đã thu thập được từ giai đoạn trước đó và cài đặt các biểu mẫu này lên interface. Sau đó, các biểu mẫu tiếp tục được sử dụng để tạo class-map và policy-map, cuối cùng, những thứ này lại được áp dụng lên interface.
Tóm tắt các bước thực hiện:
1. enable
2. configure terminal
3. interface type number
4. bandwidth kilobits
5. vbr-nrt output-pcr output-scr output-mbs [input-pcr] [input-scr] [input-mbs]
6. vbr-rt peak-rate average-rate burst
7. cbr rate
8. pvc [name] vpi/vci [ces | ilmi | qsaal | smds]
9. ip address ip-address mask [secondary]
10. frame-relay interface-dlci dlci [ietf | cisco] [voice-cir cir] [ppp virtual-template-name]
11. auto qos
12. exit

Một số sự cố thường gặp và cách xử lý:

Router không hỗ trợ tính năng AutoQoS – Enterprise:
Tính năng AutoQoS – VoIP chỉ được hỗ trợ trong các phiên bản IOS IP Plus. Kiểm tra lại IOS trên router.
Một số cấu hình QoS vẫn còn trên router khi đã gỡ bỏ tính năng AutoQoS – Enterprise:
Trường hợp này có thể do đã cấu hình thêm sau khi kích hoạt tính năng AutoQoS – Enterprise, cách duy nhất là gỡ bỏ bằng tay các cấu hình QoS còn sót lại.
Một số kết nối tốc độ thấp bị down nếu triển khai AutoQoS – Enterprise:
Phải đảm bảo rằng AutoQoS – Enterprise đã được cấu hình ở cả 2 đầu kết nối
Kết nối Frame Relay end-to-end không thực hiện được:
Phải đảm bảo là băng thông 2 đầu kết nối được cấu hình giống nhau hoàn toàn, nếu không sự phân mảnh sẽ khác nhau và kết nối bị down.

c. Kiểm tra cấu hình
Giai đoạn 2 của AutoQoS – Enterprise tự động sinh ra các biểu mẫu và từ đó xây dựng nên các class map và policy map. Để kiểm tra cấu hình có thể dùng các lệnh sau:
show auto discovery qos [interface [interface type]]
show auto qos [interface [interface type]]
show policy-map interface [interface type]

5. Ví dụ của AutoQoS – Enterprise

a. Bật giai đoạn Auto-Discovery
Dùng lệnh auto discovery qos trên interface s4/0. Trong ví dụ này, mặc dù là tùy chọn nhưng băng thông kết nối vẫn được xác định rõ. Với cấu hình này, dữ liệu sẽ được thu thập dựa vào giao thức NBAR
Router# configure terminal
Router(config)# interface s4/0
Router(config-if)# bandwidth 1540
Router(config-if)# auto discovery qos
Router(config-if)# exit

b. Bật giai đoạn tạo biểu mẫu và cài đặt
Sau khi giai đoạn AutoQoS – Enterprise kết thúc, dùng lệnh auto qos để bật giai đoạn thứ hai lên.
Router> enable
Router# configure terminal
Router(config)# interface s4/0
Router(config-if)# auto qos
Router(config-if)# exit

c. Kiểm tra cấu hình
Router# show auto discovery qos
Serial2/1.1
AutoQoS Discovery enabled for applications
Discovery up time: 2 hours, 42 minutes
AutoQoS Class information:
Class Voice:
Recommended Minimum Bandwidth: 517 Kbps/50% (PeakRate).
Detected applications and data:
Application/ AverageRate PeakRate Total
Protocol (kbps/%) (kbps/%) (bytes)
----------- ----------- -------- ------------
rtp audio 2/<1 517/50 703104
Class Interactive Video:
Recommended Minimum Bandwidth: 24 Kbps/2% (AverageRate).
Detected applications and data:
Application/ AverageRate PeakRate Total
Protocol (kbps/%) (kbps/%) (bytes)
----------- ----------- -------- ------------
rtp video 24/2 5337/52 704574
Class Control:
Recommended Minimum Bandwidth: 0 Kbps/0% (AverageRate).
Detected applications and data:
Application/ AverageRate PeakRate Total
Protocol (kbps/%) (kbps/%) (bytes)
----------- ----------- -------- ------------
h323 0/0 74/7 30212
rtcp 0/0 7/<1 1540
Class Streaming Video:
Recommended Minimum Bandwidth: 3 Kbps/<1% (AverageRate).
Detected applications and data:
Application/ AverageRate PeakRate Total
Protocol (kbps/%) (kbps/%) (bytes)
----------- ----------- -------- ------------
cuseeme 3/<1 6148/60 99038
Class Transactional:
Recommended Minimum Bandwidth: 1 Kbps/<1% (AverageRate).
Detected applications and data:
Application/ AverageRate PeakRate Total
Protocol (kbps/%) (kbps/%) (bytes)
----------- ----------- -------- ------------
sqlnet 1/<1 1706/16 40187
Class Bulk:
Recommended Minimum Bandwidth: 0 Kbps/0% (AverageRate).
Detected applications and data:
Application/ AverageRate PeakRate Total
Protocol (kbps/%) (kbps/%) (bytes)
----------- ----------- -------- ------------
ftp 0/0 313/30 74480
Class Scavenger:
Recommended Minimum Bandwidth: 1 Kbps (AverageRate)/0% (fixed).
Detected applications and data:
Application/ AverageRate PeakRate Total
Protocol (kbps/%) (kbps/%) (bytes)
----------- ----------- -------- ------------
napster 1/<1 1429/13 33941
Class Management:
Recommended Minimum Bandwidth: 0 Kbps/0% (AverageRate).
Detected applications and data:
Application/ AverageRate PeakRate Total
Protocol (kbps/%) (kbps/%) (bytes)
----------- ----------- -------- ------------
dhcp 0/0 84/8 114480
ldap 0/0 169/16 55364
Class Routing:
Recommended Minimum Bandwidth: 0 Kbps/0% (AverageRate).
Detected applications and data:
Application/ AverageRate PeakRate Total
Protocol (kbps/%) (kbps/%) (bytes)
----------- ----------- -------- ------------
icmp 0/0 2/<1 300
Class Best Effort:
Current Bandwidth Estimation: 350 Kbps/34% (AverageRate).
Detected applications and data:
Application/ AverageRate PeakRate Total
Protocol (kbps/%) (kbps/%) (bytes)
----------- ----------- -------- ------------
unknowns 336/32 99457/97 949276
http 14/1 15607/15 41945
Suggested AutoQoS Policy based on a discovery uptime of 2 hours, 42 minutes:
!
class-map match-any AutoQoS-Voice
match protocol rtp audio
!
class-map match-any AutoQoS-Inter-Video
match protocol rtp video
!
class-map match-any AutoQoS-Signaling
match protocol sip
match protocol rtcp
!
class-map match-any AutoQoS-Transactional
match protocol citrix
!
class-map match-any AutoQoS-Bulk
match protocol exchange
policy-map AutoQoS-Policy
class AutoQoS-Voice
priority percent 1
set dscp ef
class AutoQoS-Inter-Video
bandwidth remaining percent 1
set dscp af41
class AutoQoS-Signaling
bandwidth remaining percent 1
set dscp cs3
class AutoQoS-Transactional
bandwidth remaining percent 1
random-detect dscp-based
set dscp af21
class AutoQoS-Bulk
bandwidth remaining percent 1
random-detect dscp-based
set dscp af11
class class-default
fair-queue


Router# show auto qos

!
policy-map AutoQoS-Policy-Se2/1.1
class AutoQoS-Voice-Se2/1.1
priority percent 70
set dscp ef
class AutoQoS-Inter-Video-Se2/1.1
bandwidth remaining percent 10
set dscp af41
class AutoQoS-Stream-Video-Se2/1.1
bandwidth remaining percent 1
set dscp cs4
class AutoQoS-Transactional-Se2/1.1
bandwidth remaining percent 1
set dscp af21
class AutoQoS-Scavenger-Se2/1.1
bandwidth remaining percent 1
set dscp cs1
class class-default
fair-queue
!
policy-map AutoQoS-Policy-Se2/1.1-Parent
class class-default
shape average 1024000
service-policy AutoQoS-Policy-Se2/1.1
!
class-map match-any AutoQoS-Stream-Video-Se2/1.1
match protocol cuseeme
!
class-map match-any AutoQoS-Transactional-Se2/1.1
match protocol sqlnet
!
class-map match-any AutoQoS-Voice-Se2/1.1
match protocol rtp audio
!
class-map match-any AutoQoS-Scavenger-Se2/1.1
match protocol napster
!
class-map match-any AutoQoS-Inter-Video-Se2/1.1
match protocol rtp video
!
rmon event 33333 log trap AutoQoS description "AutoQoS SNMP traps for Voice Drops" own
AutoQoS
Serial2/1.1: DLCI 58 -
!
interface Serial2/1.1 point-to-point
frame-relay interface-dlci 58
class AutoQoS-FR-Serial2/1-58
!
map-class frame-relay AutoQoS-FR-Serial2/1-58
frame-relay cir 1024000
frame-relay bc 10240
frame-relay be 0
frame-relay mincir 1024000
service-policy output AutoQoS-Policy-Se2/1.1-Parent


Router# show policy-map interface

Serial2/1.1: DLCI 58 -
Service-policy output: AutoQoS-Policy-Se2/1.1-Parent
Class-map: class-default (match-any)
725797 packets, 224584146 bytes
5 minute offered rate 3468000 bps, drop rate 2605000 bps
Match: any
Traffic Shaping
Target/Average Byte Sustain Excess Interval Increment
Rate Limit bits/int bits/int (ms) (bytes)
1024000/1024000 6400 25600 25600 25 3200
Adapt Queue Packets Bytes Packets Bytes Shaping
Active Depth Delayed Delayed Active
- 1000 268047 48786251 268032 48777309 yes
Service-policy : AutoQoS-Policy-Se2/1.1
Class-map: AutoQoS-Voice-Se2/1.1 (match-any)
80596 packets, 5158144 bytes
5 minute offered rate 105000 bps, drop rate 14000 bps
Match: protocol rtp audio
80596 packets, 5158144 bytes
5 minute rate 105000 bps
Queueing
Strict Priority
Output Queue: Conversation 72
Bandwidth 70 (%)
Bandwidth 716 (kbps) Burst 17900 (Bytes)
(pkts matched/bytes matched) 82010/5248640
(total drops/bytes drops) 12501/800064
QoS Set
dscp ef
Packets marked 82010
Class-map: AutoQoS-Inter-Video-Se2/1.1 (match-any)
50669 packets, 42473594 bytes
5 minute offered rate 692000 bps, drop rate 513000 bps
Match: protocol rtp video
50669 packets, 42473594 bytes
5 minute rate 692000 bps
Queueing
Output Queue: Conversation 73
Bandwidth remaining 10 (%) Max Threshold 64 (packets)
(pkts matched/bytes matched) 51558/43218807
(depth/total drops/no-buffer drops) 9/37454/7588
QoS Set
dscp af41
Packets marked 52193
Class-map: AutoQoS-Stream-Video-Se2/1.1 (match-any)
79843 packets, 30678725 bytes
5 minute offered rate 511000 bps, drop rate 428000 bps
Match: protocol cuseeme
79843 packets, 30678725 bytes
5 minute rate 511000 bps
Queueing
Output Queue: Conversation 74
Bandwidth remaining 1 (%) Max Threshold 64 (packets)
(pkts matched/bytes matched) 82381/31658370
(depth/total drops/no-buffer drops) 0/63889/7245
QoS Set
dscp cs4
Packets marked 82395
Class-map: AutoQoS-Transactional-Se2/1.1 (match-any)
77805 packets, 8511468 bytes
5 minute offered rate 157000 bps, drop rate 102000 bps
Match: protocol sqlnet
77805 packets, 8511468 bytes
5 minute rate 157000 bps
Queueing
Output Queue: Conversation 75
Bandwidth remaining 1 (%) Max Threshold 64 (packets)
(pkts matched/bytes matched) 80635/8820988
(depth/total drops/no-buffer drops) 64/50967/3296
QoS Set
dscp af21
Packets marked 80655
Class-map: AutoQoS-Scavenger-Se2/1.1 (match-any)
30723 packets, 7127736 bytes
5 minute offered rate 136000 bps, drop rate 84000 bps
Match: protocol napster
30723 packets, 7127736 bytes
5 minute rate 136000 bps
Queueing
Output Queue: Conversation 76
Bandwidth remaining 1 (%) Max Threshold 64 (packets)
(pkts matched/bytes matched) 31785/7373950
(depth/total drops/no-buffer drops) 0/16381/6160
QoS Set
dscp cs1
Packets marked 31955
Class-map: class-default (match-any)
406161 packets, 130634479 bytes
5 minute offered rate 2033000 bps, drop rate 1703000 bps
Match: any
Queueing
Flow Based Fair Queueing
Maximum Number of Hashed Queues 64
(total queued/total drops/no-buffer drops) 806/291482/13603

imported_rosseneri
26-12-2008, 02:39 PM
Hi bạn
Cám ơn vì các thông tin rất cần thiết trên, tuy nhiên mình tìm trong bản Cisco Network Academy ONT 5.0 không thấy phần cấu hình QoS với SDM, vậy bạn có thể giới thiệu qua về phần đó hoặc tài liệu để đọc giúp mình được không
Thanks